]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Add xdg autostart config so that configuration will be applied on login.
authorNazar Mokrynskyi <nazar@mokrynskyi.com>
Sat, 1 Oct 2016 02:55:37 +0000 (05:55 +0300)
committerNazar Mokrynskyi <nazar@mokrynskyi.com>
Sat, 1 Oct 2016 02:55:37 +0000 (05:55 +0300)
Small fix for files searching.

Makefile
contrib/etc/xdg/autostart/autorandr.desktop [new file with mode: 0644]
contrib/packaging/debian/make_deb.sh

index 65d4708a0d7a562b4568ea25284115f9fb435c70..51cfd7fcd7dca5fb6c986e4880334f977f4fc8f3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
 DESTDIR=/
 PREFIX=/usr/
 
-.PHONY: all install uninstall autorandr bash_completion pmutils systemd udev
+.PHONY: all install uninstall autorandr bash_completion autostart_config pmutils systemd udev
 
 all:
        @echo "Call \"make install\" to install this program."
@@ -37,6 +37,15 @@ install_bash_completion:
 uninstall_bash_completion:
        rm -f ${DESTDIR}/${BASH_COMPLETION_DIR}/autorandr
 
+# Rules for autostart config
+XDG_AUTOSTART_DIR=/etc/xdg/autostart
+
+install_autostart_config:
+       install -D -m 644 contrib/etc/xdg/autostart/autorandr.desktop ${DESTDIR}/${XDG_AUTOSTART_DIR}/autorandr.desktop
+
+uninstall_autostart_config:
+       rm -f ${DESTDIR}/${XDG_AUTOSTART_DIR}/autorandr.desktop
+
 # Rules for pmutils
 PM_UTILS_DIR=/etc/pm/sleep.d
 HAVE_PMUTILS=$(shell [ -x /usr/sbin/pm-suspend ] && echo "y")
diff --git a/contrib/etc/xdg/autostart/autorandr.desktop b/contrib/etc/xdg/autostart/autorandr.desktop
new file mode 100644 (file)
index 0000000..47b9b9a
--- /dev/null
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=Autorandr
+Comment=Automatically select a display configuration based on connected devices
+Type=Application
+Exec=/usr/bin/autorandr -c --default default
+X-GNOME-Autostart-Phase=Initialization
index 404aaefde85fbe91083be1897d9d28115ba79986..dddc08fa69d706d27cfc6752786a22015fd16fd0 100755 (executable)
@@ -34,7 +34,7 @@ mkdir $D
 # Debian(ish) specific part
 make -C "$P/../../../" \
        DESTDIR="$D" \
-       TARGETS="autorandr bash_completion pmutils systemd udev" \
+       TARGETS="autorandr bash_completion autostart_config pmutils systemd udev" \
        BASH_COMPLETION_DIR=/usr/share/bash-completion/completions \
        SYSTEMD_UNIT_DIR=/lib/systemd/system \
        PM_UTILS_DIR=/usr/lib/pm-utils/sleep.d \
@@ -44,7 +44,7 @@ make -C "$P/../../../" \
 SIZE=$(du -s $D | awk '{print $1}')
 
 cp -r "$P/debian" "$D/DEBIAN"
-[ -d "$D/etc" ] && (cd $D; find etc) > "$D/DEBIAN/conffiles"
+[ -d "$D/etc" ] && (cd $D; find etc -type f) > "$D/DEBIAN/conffiles"
 sed -i -re "s#Version:.+#Version: $V#" "$D/DEBIAN/control"
 echo "Installed-Size: $SIZE" >> "$D/DEBIAN/control"
 fakeroot dpkg-deb -b "$D" "$O"