]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Switch to using python3 (Closes: #936170)
authorDon Armstrong <don@donarmstrong.com>
Fri, 30 Aug 2019 07:33:10 +0000 (00:33 -0700)
committerDon Armstrong <don@donarmstrong.com>
Fri, 30 Aug 2019 07:33:10 +0000 (00:33 -0700)
debian/changelog
debian/control
debian/patches/series [new file with mode: 0644]
debian/patches/use_python3 [new file with mode: 0644]

index 3e03efce3171bea92f1e01e61539e5a80e9f49c5..2ab0479ef15a9f6b4a7688c5326e5705d8d4226e 100644 (file)
@@ -1,3 +1,10 @@
+autorandr (1.8.1-2) unstable; urgency=medium
+
+  * Switch to using python3 by changing the #! line and dependencies; no
+    other changes were required (Closes: #936170)
+
+ -- Don Armstrong <don@debian.org>  Fri, 30 Aug 2019 00:30:36 -0700
+
 autorandr (1.8.1-1) unstable; urgency=medium
 
   * New upstream release
index d270d399f38f74e08a7854b92e6b287aa636fa88..b8f1c716f456226e558fbf4f0e70f9c90edc0e2a 100644 (file)
@@ -11,7 +11,7 @@ Vcs-Browser: https://git.donarmstrong.com/deb_pkgs/autorandr.git
 
 Package: autorandr
 Architecture: all
-Depends: x11-xserver-utils, python, ${misc:Depends}
+Depends: x11-xserver-utils, python3, ${misc:Depends}
 Description: Automatically select a display configuration for connected devices
  Autorandr is a script for managing xrandr configurations based on the
  connected devices. It can be set up to automatically switch to a
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644 (file)
index 0000000..ee77c53
--- /dev/null
@@ -0,0 +1 @@
+use_python3
diff --git a/debian/patches/use_python3 b/debian/patches/use_python3
new file mode 100644 (file)
index 0000000..c5c93ab
--- /dev/null
@@ -0,0 +1,12 @@
+Description: Debian specific patch to switch from python to python3
+Bug-Debian: https://bugs.debian.org/936170
+Author: Don Armstrong <don@debian.org>
+Forwarded: not-needed
+--- a/autorandr.py
++++ b/autorandr.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # encoding: utf-8
+ #
+ # autorandr.py