]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Fix modified dictionary iteration as 1.12.1 1.12.1
authorPhillip Berndt <phillip.berndt@googlemail.com>
Wed, 22 Dec 2021 12:25:35 +0000 (13:25 +0100)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Wed, 22 Dec 2021 12:28:03 +0000 (13:28 +0100)
See #273

README.md
autorandr.py
contrib/packaging/rpm/autorandr.spec
setup.py

index d9785937cb517518194a7c0bb5f7c566e92e6838..7d320a174605e3c93340fbf958f09771487f4976 100644 (file)
--- a/README.md
+++ b/README.md
@@ -249,6 +249,9 @@ options nvidia_drm modeset=1
 
 ## Changelog
 
+**autorandr 1.12.1**
+* *2021-12-22* Fix `--match-edid` (see #273)
+
 **autorandr 1.12**
 * *2021-12-16* Switch default interpreter to Python 3
 * *2021-12-16* Add `--list` to list all profiles
index 73ae1dce2092d80e5774a91bca2ab48bb1c6a5e4..6d0163c0a4dc9fd1f207865101206dae00915ec1 100755 (executable)
@@ -53,7 +53,7 @@ if sys.version_info.major == 2:
 else:
     import configparser
 
-__version__ = "1.12"
+__version__ = "1.12.1"
 
 try:
     input = raw_input
@@ -649,7 +649,7 @@ def update_profiles_edid(profiles, config):
         profile_config = profiles[p]["config"]
 
         for edid in edid_map:
-            for c in profile_config.keys():
+            for c in list(profile_config.keys()):
                 if profile_config[c].edid != edid or c == edid_map[edid]:
                     continue
 
index efb3c4f9f76aadc2622f3caba2c74f4ac02d0e2f..26533df59ff8173ea829b40532b1c579043e06c3 100644 (file)
@@ -1,5 +1,5 @@
 Name:           autorandr
-Version:        1.12
+Version:        1.12.1
 Release:        %autorelease
 Summary:        Automatically select a display configuration based on connected devices
 
index c3f18586c707d205707d106bb2d599f56d2a08b4..ed729ba60edd2cb83791cbbde7eed3510fea4ac2 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ except:
 setup(
     name='autorandr',
 
-    version='1.12.post1',
+    version='1.12.1.post1',
 
     description='Automatically select a display configuration based on connected devices',
     long_description=long_description,
@@ -35,7 +35,11 @@ setup(
         'Programming Language :: Python :: 3',
         'Programming Language :: Python :: 3.3',
         'Programming Language :: Python :: 3.4',
-        'Programming Language :: Python :: 3.5',
+        'Programming Language :: Python :: 3.6',
+        'Programming Language :: Python :: 3.7',
+        'Programming Language :: Python :: 3.8',
+        'Programming Language :: Python :: 3.9',
+        'Programming Language :: Python :: 3.10',
     ],
 
     keywords='xrandr',