]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Merge remote-tracking branch 'helterscelter/master'
authorPhillip Berndt <phillip.berndt@googlemail.com>
Mon, 2 Dec 2013 09:34:24 +0000 (10:34 +0100)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Mon, 2 Dec 2013 09:34:24 +0000 (10:34 +0100)
Conflicts:
pm-utils/40autorandr

Makefile [new file with mode: 0644]
README [deleted file]
README.md [new file with mode: 0644]
autorandr
bash_completion/autorandr
pm-utils/40autorandr
udev/40-monitor-hotplug.rules [new file with mode: 0644]

diff --git a/Makefile b/Makefile
new file mode 100644 (file)
index 0000000..41494fa
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+all:
+       @echo "Call \"make install\" to install this program."
+       @echo "Call \"make hotplug\" to install matching hotplug events."
+
+INSTALL_PATH=/usr/local/bin
+install:
+       install auto-disper ${INSTALL_PATH}
+       install -m 755 autorandr ${INSTALL_PATH}
+       install -m 644 bash_completion/autorandr /etc/bash_completion.d/
+
+hotplug:
+       install -m 755 pm-utils/40autorandr /etc/pm/sleep.d/
+       install -m 644 udev/40-monitor-hotplug.rules /etc/udev/rules.d/
+       udevadm control --reload-rules
\ No newline at end of file
diff --git a/README b/README
deleted file mode 100644 (file)
index 9b54600..0000000
--- a/README
+++ /dev/null
@@ -1,46 +0,0 @@
-Tool: "autorandr"
-
-Automatically select a display configuration based on connected devices
-
-Stefan Tomanek <stefan.tomanek@wertarbyte.de>
-
-How to use:
-
-Save your current display configuration and setup with:
- $ autorandr --save mobile
-
-Connect an additional display, configure your setup and save it:
- $ autorandr --save docked
-
-Now autorandr can detect which hardware setup is active:
- $ autorandr
-   mobile
-   docked (detected)
-
-To automatically reload your setup, just append --change to the command line
-
-To manually load a profile, you can use the --load <profile> option.
-
-autorandr tries to avoid reloading an identical configuration. To force the
-(re)configuration, apply --force.
-
-To prevent a profile from being loaded, place a script call "block" in its
-directory. The script is evaluated before the screen setup is inspected, and
-in case of it returning a value of 0 the profile is skipped. This can be used
-to query the status of a docking station you are about to leave.
-
-If no suitable profile can be identified, the current configuration is kept.
-To change this behaviour and switch to a fallback configuration, specify
---default <profile>
-
-Another script called "postswitch "can be placed in the directory
-~/.autorandr as well as in all profile directories: The scripts are executed
-after a mode switch has taken place and can notify window managers or other
-applications about it.
-
-
-While the script uses xrandr by default, calling it by the name "autodisper"
-or "auto-disper" forces it to use the "disper" utility, which is useful for
-controlling nvidia chipsets. The formats for fingerprinting the current setup
-and saving/loading the current configuration are adjusted accordingly.
-
diff --git a/README.md b/README.md
new file mode 100644 (file)
index 0000000..aa66042
--- /dev/null
+++ b/README.md
@@ -0,0 +1,62 @@
+# autorandr
+
+Automatically select a display configuration based on connected devices
+
+Stefan Tomanek <[stefan.tomanek@wertarbyte.de](stefan.tomanek@wertarbyte.de)>
+
+## Branch information
+
+The original wertarbyte/autorandr tree seems unmaintained, with lots of open
+pull requests and issues. I forked it and merged what I thought were the most
+important changes. I will maintain this branch until wertarbyte finds the time
+to maintain his branch again.
+
+
+## How to use
+
+Save your current display configuration and setup with:
+```
+autorandr --save mobile
+```
+
+Connect an additional display, configure your setup and save it:
+```
+autorandr --save docked
+```
+
+Now autorandr can detect which hardware setup is active:
+```
+ $ autorandr
+   mobile
+   docked (detected)
+```
+
+To automatically reload your setup, just append `--change` to the command line
+
+To manually load a profile, you can use the `--load <profile>` option.
+
+autorandr tries to avoid reloading an identical configuration. To force the
+(re)configuration, apply `--force`.
+
+To prevent a profile from being loaded, place a script call _block_ in its
+directory. The script is evaluated before the screen setup is inspected, and
+in case of it returning a value of 0 the profile is skipped. This can be used
+to query the status of a docking station you are about to leave.
+
+If no suitable profile can be identified, the current configuration is kept.
+To change this behaviour and switch to a fallback configuration, specify
+`--default <profile>`.
+
+Another script called `postswitch` can be placed in the directory
+`~/.autorandr` as well as in all profile directories: The scripts are executed
+after a mode switch has taken place and can notify window managers or other
+applications about it.
+
+While the script uses xrandr by default, calling it by the name `autodisper`
+or `auto-disper` forces it to use the [disper](http://willem.engen.nl/projects/disper/)
+utility, which is useful for controlling nvidia chipsets. The formats for
+fingerprinting the current setup and saving/loading the current configuration
+are adjusted accordingly.
+
+To install autorandr call `make install`, define your setup and then call
+`make hotplug` to install hotplug scripts.
index c14f5cbc9d5ef33b62ce21c36488508194823189..08725363e1627a52bb2f2f7bcbb7162644c754c9 100755 (executable)
--- a/autorandr
+++ b/autorandr
@@ -121,12 +121,22 @@ current_cfg_xrandr() {
        $XRANDR -q | awk -v primary_setup="${PRIMARY_SETUP}" '
        # display is connected and has a mode
        /^[^ ]+ connected [^(]/ {
-               split($3, A, "+");
                print "output "$1;
+               if ($3 == "primary") {
+                       print $3
+                       split($4, A, "+")
+                       $4=$5
+               }
+               else {
+                       split($3, A, "+");
+                       if (A[1] A[2] "," A[3] == primary_setup)
+                               print "primary";
+               }
                print "mode "A[1];
                print "pos "A[2]"x"A[3];
-               if (A[1] A[2] "," A[3] == primary_setup)
-                       print "primary";
+               if ($4 !~ /^\(/) {
+                       print "rotate "$4;
+               }
                next;
        }
        # disconnected or disabled displays
@@ -164,7 +174,28 @@ config_equal() {
 }
 
 load_cfg_xrandr() {
-       sed 's!^!--!' "$1" | xargs $XRANDR
+       # sed 1: Prefix arguments with "--"
+       # sed 2: Merge arguments into one line per output
+       # sed 3: Merge into two lines, all --off outputs in the first one
+       sed 's/^/--/' "$1" | sed -e '
+               :START
+               /\n--output/{P;D}
+               s/\n/ /
+               N;bSTART' | sed -e '
+                       ### First line
+                       / --off/{
+                               G
+                               # Merge if next line contains --off
+                               s/\n\([^\n]* --off\)/ \1/
+                               h
+                               $!d;b
+                       }
+                       ### Last line
+                       H;x
+                       # Merge if previous line contains --mode
+                       s/\(--mode [^\n]*\)\n/\1 /
+                       h
+                       $!d' | xargs -L 1 $XRANDR
 }
 
 load_cfg_disper() {
@@ -196,6 +227,7 @@ Usage: $SCRIPTNAME [options]
 -d, --default <profile> make profile <profile> the default profile 
 --force                        force (re)loading of a profile
 --fingerprint          fingerprint your current hardware setup
+--config               dump your current xrandr setup
 
  To prevent a profile from being loaded, place a script call "block" in its
  directory. The script is evaluated before the screen setup is inspected, and
@@ -217,7 +249,7 @@ EOH
        exit
 }
 # process parameters
-OPTS=$(getopt -n autorandr -o s:l:d:cfh --long change,default:,save:,load:,force,fingerprint,help -- "$@")
+OPTS=$(getopt -n autorandr -o s:l:d:cfh --long change,default:,save:,load:,force,fingerprint,config,help -- "$@")
 if [ $? != 0 ] ; then echo "Terminating..." >&2 ; exit 1 ; fi
 eval set -- "$OPTS"
 
@@ -230,6 +262,7 @@ while true; do
                -h|--help) help ;; 
                --force) FORCE_LOAD=1; shift ;;
                --fingerprint) setup_fp; exit 0;;
+               --config) current_cfg; exit 0;;
                --) shift; break ;;
                *) echo "Error: $1"; exit 1;;
        esac
index b00999452fdb4d4cb1b73ebc1ece66793858cccd..151c59698807c5b7de8d2a7ebc43b5677d88ecb0 100644 (file)
@@ -10,7 +10,11 @@ _autorandr ()
 
        opts="-h -c -s -l -d"
        lopts="--help --change --save --load --default --force --fingerprint"
-       prfls="`find ~/.autorandr/* -maxdepth 1 -type d -printf '%f\n'`"
+       if [ -d ~/.autorandr ]; then
+               prfls="`find ~/.autorandr/* -maxdepth 1 -type d -printf '%f\n'`"
+       else
+               prfls=""
+       fi
 
        case "${cur}" in
                --*)
index f465b06d4d4bdb6d8395bb6e79999bb49b2958a3..4ce7790255d1041db62637f495d1625912306441 100755 (executable)
@@ -1,6 +1,7 @@
 #!/bin/sh
 #
 # 40autorandr: Change autorandr profile on thaw/resume
+exec > /var/log/autorandr.log 2>&1
 
 # detect if we are being called as 40auto-disper or 40autorandr
 FORM=${0##*40}
@@ -12,16 +13,14 @@ case $FORM in
                AUTORANDR="autorandr -c"
                ;;
 esac
-echo "$AUTORANDR"
 
 detect_display()
 {
        for X in /tmp/.X11-unix/X*; do
                D="${X##/tmp/.X11-unix/X}"
-               user=$( who | grep  \(:$D\) | cut -d ' ' -sf 1 | uniq )
-               echo "Checking $X -- $D - $user"
+               user=$(w -h | awk -vD="$D" '$3 ~ ":"D"(\\.[0-9])?$" {print $1}' | head -1)
                if [ x"$user" != x"" ]; then
-                       echo "AUTORANDR $D - $user"
+                       logger "autorandr: Changing display configuration for user '$user'"
                        export DISPLAY=":$D"
                        /bin/su -c "${AUTORANDR}" "$user"
                fi
@@ -31,6 +30,6 @@ detect_display()
 
 case "$1" in
        thaw|resume)
-               detect_display 
+               detect_display
                ;;
 esac
diff --git a/udev/40-monitor-hotplug.rules b/udev/40-monitor-hotplug.rules
new file mode 100644 (file)
index 0000000..4c48ffb
--- /dev/null
@@ -0,0 +1 @@
+ACTION=="change", SUBSYSTEM=="drm", RUN+="/etc/pm/sleep.d/40autorandr thaw"