]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
pip installable!
authorDaniel Schep <dschep@gmail.com>
Wed, 30 Nov 2016 01:37:05 +0000 (20:37 -0500)
committerDaniel Schep <dschep@gmail.com>
Wed, 30 Nov 2016 13:04:13 +0000 (08:04 -0500)
README.md
setup.py [new file with mode: 0644]

index 070a453f20c500c0e4d763c8657912e2a995de2c..6b90d4d0cb7c7b094b682901d5a6436314514385 100644 (file)
--- a/README.md
+++ b/README.md
@@ -70,6 +70,11 @@ list of what exactly will be installed.
 We appreciate packaging scripts for other distributions, please file a pull
 request if you write one.
 
 We appreciate packaging scripts for other distributions, please file a pull
 request if you write one.
 
+On any distribution with `pip` installed you can install it with:
+```
+sudo pip install -e git+http://github.com/phillipberndt/autorandr#egg=autorandr
+```
+
 ## How to use
 
 Save your current display configuration and setup with:
 ## How to use
 
 Save your current display configuration and setup with:
diff --git a/setup.py b/setup.py
new file mode 100644 (file)
index 0000000..b413717
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,45 @@
+from setuptools import setup
+
+
+long_description = open('README.md').read()
+
+setup(
+    name='autorandr',
+
+    #version='', # FIXME
+
+    description='Automatically select a display configuration based on connected devices',
+    long_description=long_description,
+
+    url='https://github.com/phillipberndt/autorandr',
+
+    author='Phillip Berndt',
+
+    license='GPLv3',
+
+    # See https://pypi.python.org/pypi?%3Aaction=list_classifiers
+    classifiers=[
+        'Environment :: Console',
+
+        'Intended Audience :: End Users/Desktop',
+
+        'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
+
+        'Programming Language :: Python :: 2',
+        'Programming Language :: Python :: 2.7',
+        'Programming Language :: Python :: 3',
+        'Programming Language :: Python :: 3.3',
+        'Programming Language :: Python :: 3.4',
+        'Programming Language :: Python :: 3.5',
+    ],
+
+    keywords='xrandr',
+
+    py_modules=['autorandr'],
+
+    entry_points={
+        'console_scripts': [
+            'autorandr = autorandr:exception_handled_main',
+        ],
+    },
+)