]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Merge remote-tracking branch 'queezythegreat/master'
authorPhillip Berndt <phillip.berndt@googlemail.com>
Mon, 2 Dec 2013 09:50:40 +0000 (10:50 +0100)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Mon, 2 Dec 2013 09:50:40 +0000 (10:50 +0100)
Conflicts:
Makefile

Makefile
contrib/autorandr_monitor/Xsession.d/autorandr [new file with mode: 0644]
contrib/autorandr_monitor/autorandr_monitor [new file with mode: 0755]

index 41494faedfabc0773b4351c90f7ff7e8377b26fd..a22a058c0d1e80e09fdc24ee129e534914b48413 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,4 +11,4 @@ install:
 hotplug:
        install -m 755 pm-utils/40autorandr /etc/pm/sleep.d/
        install -m 644 udev/40-monitor-hotplug.rules /etc/udev/rules.d/
-       udevadm control --reload-rules
\ No newline at end of file
+       udevadm control --reload-rules
diff --git a/contrib/autorandr_monitor/Xsession.d/autorandr b/contrib/autorandr_monitor/Xsession.d/autorandr
new file mode 100644 (file)
index 0000000..d0b568a
--- /dev/null
@@ -0,0 +1,3 @@
+# -*- sh -*-
+
+/usr/bin/autorandr_monitor &> /tmp/autorandr_monitor &
diff --git a/contrib/autorandr_monitor/autorandr_monitor b/contrib/autorandr_monitor/autorandr_monitor
new file mode 100755 (executable)
index 0000000..6f369bb
--- /dev/null
@@ -0,0 +1,53 @@
+#!/usr/bin/env python
+""""
+Author:  Tomasz Bogdal (a.k.a. QueezyTheGreat)
+Home:    https://github.com/queezythegreat/autorandr
+License: This Source Code Form is subject to the terms of the
+         Mozilla Public License, v. 2.0
+"""
+import os
+import pyinotify
+from pyinotify import ProcessEvent
+
+#TODO: Fork off when started
+#TODO: Add configuration file
+#TODO: Add command line options
+
+SYS_VIDEO_OUTPUTS='/sys/class/drm/'
+DEFAULT_PROFILE='default'
+AUTORANDR_CMD='autorandr --change --default %s' % DEFAULT_PROFILE
+
+class VideoOutputMonitor(ProcessEvent):
+    """ Launch autorandr when video card output status is changed. """
+
+    def process_IN_ACCESS(self, event):
+        """ Handle IN_ACCESS events to `status` file. """
+        if event.name == 'status':
+            print 'Change status of %s' % os.path.basename(event.path)
+            os.system(AUTORANDR_CMD)
+
+
+def register_video_cards(manager):
+    """ Register all video card ouptus for monitoring. """
+    if not os.path.exists(SYS_VIDEO_OUTPUTS):
+        return
+
+    for directory in os.listdir(SYS_VIDEO_OUTPUTS):
+        path = os.path.join(SYS_VIDEO_OUTPUTS, directory)
+        status = os.path.join(path, 'status')
+        if os.path.exists(status):
+            print 'Monitoring %s' % path
+            manager.add_watch(path, pyinotify.ALL_EVENTS)
+
+def main():
+    # pyinotify.log.setLevel(10)
+    manager = pyinotify.WatchManager()
+    handler = VideoOutputMonitor()
+    notifier = pyinotify.Notifier(manager, default_proc_fun=handler)
+
+    register_video_cards(manager)
+
+    notifier.loop()
+
+if __name__ == '__main__':
+    main()