]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Merge remote-tracking branch 'mtahmed/master'
authorPhillip Berndt <phillip.berndt@googlemail.com>
Fri, 29 Nov 2013 06:58:56 +0000 (07:58 +0100)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Fri, 29 Nov 2013 06:58:56 +0000 (07:58 +0100)
Conflicts:
README.md

Makefile [new file with mode: 0644]
README.md
autorandr
bash_completion/autorandr
pm-utils/40autorandr
udev/40-monitor-hotplug.rules [new file with mode: 0644]

diff --git a/Makefile b/Makefile
new file mode 100644 (file)
index 0000000..41494fa
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+all:
+       @echo "Call \"make install\" to install this program."
+       @echo "Call \"make hotplug\" to install matching hotplug events."
+
+INSTALL_PATH=/usr/local/bin
+install:
+       install auto-disper ${INSTALL_PATH}
+       install -m 755 autorandr ${INSTALL_PATH}
+       install -m 644 bash_completion/autorandr /etc/bash_completion.d/
+
+hotplug:
+       install -m 755 pm-utils/40autorandr /etc/pm/sleep.d/
+       install -m 644 udev/40-monitor-hotplug.rules /etc/udev/rules.d/
+       udevadm control --reload-rules
\ No newline at end of file
index d09b386bb355e760442b217e995c2520ae7e566d..aa66042483e9730266d6635c8379b5d7b310bc05 100644 (file)
--- a/README.md
+++ b/README.md
@@ -4,6 +4,14 @@ Automatically select a display configuration based on connected devices
 
 Stefan Tomanek <[stefan.tomanek@wertarbyte.de](stefan.tomanek@wertarbyte.de)>
 
+## Branch information
+
+The original wertarbyte/autorandr tree seems unmaintained, with lots of open
+pull requests and issues. I forked it and merged what I thought were the most
+important changes. I will maintain this branch until wertarbyte finds the time
+to maintain his branch again.
+
+
 ## How to use
 
 Save your current display configuration and setup with:
@@ -44,9 +52,11 @@ Another script called `postswitch` can be placed in the directory
 after a mode switch has taken place and can notify window managers or other
 applications about it.
 
-
 While the script uses xrandr by default, calling it by the name `autodisper`
 or `auto-disper` forces it to use the [disper](http://willem.engen.nl/projects/disper/)
 utility, which is useful for controlling nvidia chipsets. The formats for
 fingerprinting the current setup and saving/loading the current configuration
 are adjusted accordingly.
+
+To install autorandr call `make install`, define your setup and then call
+`make hotplug` to install hotplug scripts.
index c2c3384e06e25d7de2e938a253efe82aeb773308..08725363e1627a52bb2f2f7bcbb7162644c754c9 100755 (executable)
--- a/autorandr
+++ b/autorandr
@@ -121,15 +121,22 @@ current_cfg_xrandr() {
        $XRANDR -q | awk -v primary_setup="${PRIMARY_SETUP}" '
        # display is connected and has a mode
        /^[^ ]+ connected [^(]/ {
-               split($3, A, "+");
                print "output "$1;
+               if ($3 == "primary") {
+                       print $3
+                       split($4, A, "+")
+                       $4=$5
+               }
+               else {
+                       split($3, A, "+");
+                       if (A[1] A[2] "," A[3] == primary_setup)
+                               print "primary";
+               }
                print "mode "A[1];
                print "pos "A[2]"x"A[3];
                if ($4 !~ /^\(/) {
                        print "rotate "$4;
                }
-               if (A[1] A[2] "," A[3] == primary_setup)
-                       print "primary";
                next;
        }
        # disconnected or disabled displays
@@ -167,7 +174,28 @@ config_equal() {
 }
 
 load_cfg_xrandr() {
-       sed 's!^!--!' "$1" | xargs $XRANDR
+       # sed 1: Prefix arguments with "--"
+       # sed 2: Merge arguments into one line per output
+       # sed 3: Merge into two lines, all --off outputs in the first one
+       sed 's/^/--/' "$1" | sed -e '
+               :START
+               /\n--output/{P;D}
+               s/\n/ /
+               N;bSTART' | sed -e '
+                       ### First line
+                       / --off/{
+                               G
+                               # Merge if next line contains --off
+                               s/\n\([^\n]* --off\)/ \1/
+                               h
+                               $!d;b
+                       }
+                       ### Last line
+                       H;x
+                       # Merge if previous line contains --mode
+                       s/\(--mode [^\n]*\)\n/\1 /
+                       h
+                       $!d' | xargs -L 1 $XRANDR
 }
 
 load_cfg_disper() {
index b00999452fdb4d4cb1b73ebc1ece66793858cccd..151c59698807c5b7de8d2a7ebc43b5677d88ecb0 100644 (file)
@@ -10,7 +10,11 @@ _autorandr ()
 
        opts="-h -c -s -l -d"
        lopts="--help --change --save --load --default --force --fingerprint"
-       prfls="`find ~/.autorandr/* -maxdepth 1 -type d -printf '%f\n'`"
+       if [ -d ~/.autorandr ]; then
+               prfls="`find ~/.autorandr/* -maxdepth 1 -type d -printf '%f\n'`"
+       else
+               prfls=""
+       fi
 
        case "${cur}" in
                --*)
index 60ca9ae8f374b3d4d9a1ab144863428758f546fb..43c17667f814bdfcded67a2060aeabe1bc630de1 100755 (executable)
@@ -1,6 +1,7 @@
 #!/bin/sh
 #
 # 40autorandr: Change autorandr profile on thaw/resume
+exec > /var/log/autorandr.log 2>&1
 
 AUTORANDR="autorandr -c"
 
@@ -8,7 +9,8 @@ detect_display()
 {
        for X in /tmp/.X11-unix/X*; do
                D="${X##/tmp/.X11-unix/X}"
-               user=$(who | awk -vD="$D" '$5 ~ "\\(:"D"\\)$" {print $1}')
+               user=$(w -h | awk -vD="$D" '$3 ~ ":"D"(\\.[0-9])?$" {print $1}' | head -1)
+               logger "autorandr: Changing display configuration for user '$user'"
                if [ x"$user" != x"" ]; then
                        export DISPLAY=":$D"
                        /bin/su -c "${AUTORANDR}" "$user"
diff --git a/udev/40-monitor-hotplug.rules b/udev/40-monitor-hotplug.rules
new file mode 100644 (file)
index 0000000..4c48ffb
--- /dev/null
@@ -0,0 +1 @@
+ACTION=="change", SUBSYSTEM=="drm", RUN+="/etc/pm/sleep.d/40autorandr thaw"