]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
udev requires pmutils as well (See issue #45)
[deb_pkgs/autorandr.git] / Makefile
index a8ed7931d3d49f2c4d999083c615c14d3983180f..a312da8fde60c30c0d4ef038af2e7900407d8591 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,13 +39,13 @@ DEFAULT_TARGETS+=pmutils
 endif
 
 install_pmutils:
-       install -D -m 644 contrib/pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
+       install -D -m 755 contrib/pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 uninstall_pmutils:
        rm -f ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 # Rules for systemd
-HAVE_SYSTEMD=$(shell grep -q systemd $$(readlink -f $$(cat /proc/1/cmdline)) && echo "y")
+HAVE_SYSTEMD=$(shell grep -q systemd /proc/1/comm && echo "y")
 ifeq ($(HAVE_SYSTEMD),y)
 DEFAULT_TARGETS+=systemd
 endif
@@ -62,7 +62,7 @@ ifeq ($(HAVE_UDEV),y)
 DEFAULT_TARGETS+=udev
 endif
 
-install_udev:
+install_udev: install_pmutils
        install -D -m 644 contrib/udev/40-monitor-hotplug.rules ${DESTDIR}/etc/udev/rules.d/40-monitor-hotplug.rules
 ifeq (${USER},root)
        udevadm control --reload-rules
@@ -71,7 +71,7 @@ else
        @echo "    udevadm control --reload-rules"
 endif
 
-uninstall_udev:
+uninstall_udev: uninstall_pmutils
        rm -f ${DESTDIR}/etc/udev/rules.d/40-monitor-hotplug.rules