]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Add xdg autostart config so that configuration will be applied on login.
[deb_pkgs/autorandr.git] / Makefile
index 65d4708a0d7a562b4568ea25284115f9fb435c70..51cfd7fcd7dca5fb6c986e4880334f977f4fc8f3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
 DESTDIR=/
 PREFIX=/usr/
 
-.PHONY: all install uninstall autorandr bash_completion pmutils systemd udev
+.PHONY: all install uninstall autorandr bash_completion autostart_config pmutils systemd udev
 
 all:
        @echo "Call \"make install\" to install this program."
@@ -37,6 +37,15 @@ install_bash_completion:
 uninstall_bash_completion:
        rm -f ${DESTDIR}/${BASH_COMPLETION_DIR}/autorandr
 
+# Rules for autostart config
+XDG_AUTOSTART_DIR=/etc/xdg/autostart
+
+install_autostart_config:
+       install -D -m 644 contrib/etc/xdg/autostart/autorandr.desktop ${DESTDIR}/${XDG_AUTOSTART_DIR}/autorandr.desktop
+
+uninstall_autostart_config:
+       rm -f ${DESTDIR}/${XDG_AUTOSTART_DIR}/autorandr.desktop
+
 # Rules for pmutils
 PM_UTILS_DIR=/etc/pm/sleep.d
 HAVE_PMUTILS=$(shell [ -x /usr/sbin/pm-suspend ] && echo "y")