]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blob - contrib/packaging/rpm/autorandr.spec
rpm spec file update to 1.10.1
[deb_pkgs/autorandr.git] / contrib / packaging / rpm / autorandr.spec
1 %define name autorandr
2 %define version 1.10.1
3 %define release 1
4
5 # pmutils
6 %define use_pm_utils 1
7 %if 0%{?fedora} > 22
8 %define use_pm_utils 0
9 %endif
10 %if 0%{?rhel} > 7
11 %define use_pm_utils 0
12 %endif
13
14 # python 2 or 3
15 %define py_ver 3
16 %if 0%{?rhel}
17 %define py_ver 2
18 %endif
19
20 Summary: Automatically select a display configuration based on connected devices
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}%{?dist}
24 Source0: https://github.com/phillipberndt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
25 License: GPLv3
26 Group: Development/Libraries
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
28 Prefix: %{_prefix}
29 BuildArch: noarch
30 Vendor: Phillip Berndt <phillip.berndt@googlemail.com>
31 Url: https://github.com/phillipberndt/autorandr
32 Requires: python%{py_ver}
33 %if 0%{?use_pm_utils}
34 Requires:       pm-utils
35 %endif
36 %{?systemd_ordering}
37 BuildRequires: bash-completion
38 BuildRequires: python%{py_ver}-devel
39 BuildRequires: systemd
40 BuildRequires: udev
41
42 %description
43 # autorandr
44
45 Automatically select a display configuration based on connected devices
46
47 ## Branch information
48
49 This is a compatible Python rewrite of
50 [wertarbyte/autorandr](https://github.com/wertarbyte/autorandr). Contributions
51 for bash-completion, fd.o/XDG autostart, Nitrogen, pm-utils, and systemd can be
52 found under [contrib](contrib/).
53
54 The original [wertarbyte/autorandr](https://github.com/wertarbyte/autorandr)
55 tree is unmaintained, with lots of open pull requests and issues. I forked it
56 and merged what I thought were the most important changes. If you are searching
57 for that version, see the [`legacy` branch](https://github.com/phillipberndt/autorandr/tree/legacy).
58 Note that the Python version is better suited for non-standard configurations,
59 like if you use `--transform` or `--reflect`. If you use `auto-disper`, you
60 have to use the bash version, as there is no disper support in the Python
61 version (yet). Both versions use a compatible configuration file format, so
62 you can, to some extent, switch between them.  I will maintain the `legacy`
63 branch until @wertarbyte finds the time to maintain his branch again.
64
65 If you are interested in why there are two versions around, see
66 [#7](https://github.com/phillipberndt/autorandr/issues/7),
67 [#8](https://github.com/phillipberndt/autorandr/issues/8) and
68 especially
69 [#12](https://github.com/phillipberndt/autorandr/issues/12)
70 if you are unhappy with this version and would like to contribute to the bash
71 version.
72
73 ## License information and authors
74
75 autorandr is available under the terms of the GNU General Public License
76 (version 3).
77
78 Contributors to this version of autorandr are:
79
80 * Adrián López
81 * andersonjacob
82 * Alexander Wirt
83 * Brice Waegeneire
84 * Chris Dunder
85 * Christoph Gysin
86 * Christophe-Marie Duquesne
87 * Daniel Hahler
88 * Maciej Sitarz
89 * Mathias Svensson
90 * Matthew R Johnson
91 * Nazar Mokrynskyi
92 * Phillip Berndt
93 * Rasmus Wriedt Larsen
94 * Simon Wydooghe
95 * Stefan Tomanek
96 * stormc
97 * tachylatus
98 * Timo Bingmann
99 * Timo Kaufmann
100 * Tomasz Bogdal
101 * Victor Häggqvist
102 * Jan-Oliver Kaiser
103
104 ## Installation/removal
105
106 You can use the `autorandr.py` script as a stand-alone binary. If you'd like to
107 install it as a system-wide application, there is a Makefile included that also
108 places some configuration files in appropriate directories such that autorandr
109 is invoked automatically when a monitor is connected or removed, the system
110 wakes up from suspend, or a user logs into an X11 session. Run `make install`
111 as root to install it.
112
113 If you prefer to have a system wide install managed by your package manager,
114 you can
115
116 * Use the [official Arch package](https://www.archlinux.org/packages/community/any/autorandr/).
117 * Use the [official Debian package](https://packages.debian.org/sid/x11/autorandr) on sid
118 * Use the [ebuild from zugaina](https://gpo.zugaina.org/x11-misc/autorandr) on Gentoo.
119 * Use the
120   [nix package](https://github.com/NixOS/nixpkgs/blob/master/nixos/modules/services/misc/autorandr.nix)
121   on NixOS.
122 * Use the automated nightlies generated by the
123   [openSUSE build service](https://build.opensuse.org/package/show/home:phillipberndt/autorandr)
124   for various distributions (RPM and DEB based).
125 * Use the [X binary package system](https://wiki.voidlinux.eu/XBPS)' on Void Linux 
126 * Build a .deb-file from the source tree using `make deb`.
127 * Build a .rpm-file from the source tree using `make rpm`.
128
129 We appreciate packaging scripts for other distributions, please file a pull
130 request if you write one.
131
132 If you prefer `pip` over your package manager, you can install autorandr with:
133
134     sudo pip install "git+http://github.com/phillipberndt/autorandr#egg=autorandr"
135
136 or simply
137
138     sudo pip install autorandr
139
140 if you prefer to use a stable version.
141
142 ## How to use
143
144 Save your current display configuration and setup with:
145
146     autorandr --save mobile
147
148 Connect an additional display, configure your setup and save it:
149
150     autorandr --save docked
151
152 Now autorandr can detect which hardware setup is active:
153
154     $ autorandr
155       mobile
156       docked (detected)
157
158 To automatically reload your setup:
159
160     $ autorandr --change
161
162 To manually load a profile:
163
164     $ autorandr --load <profile>
165
166 or simply:
167
168     $ autorandr <profile>
169
170 autorandr tries to avoid reloading an identical configuration. To force the
171 (re)configuration:
172
173     $ autorandr --load <profile> --force
174
175 To prevent a profile from being loaded, place a script call _block_ in its
176 directory. The script is evaluated before the screen setup is inspected, and
177 in case of it returning a value of 0 the profile is skipped. This can be used
178 to query the status of a docking station you are about to leave.
179
180 If no suitable profile can be identified, the current configuration is kept.
181 To change this behaviour and switch to a fallback configuration, specify
182 `--default <profile>`. The system-wide installation of autorandr by default
183 calls autorandr with a parameter `--default default`. There are three special,
184 virtual configurations called `horizontal`, `vertical` and `common`. They
185 automatically generate a configuration that incorporates all screens
186 connected to the computer. You can symlink `default` to one of these
187 names in your configuration directory to have autorandr use any of them
188 as the default configuration without you having to change the system-wide
189 configuration.
190
191 You can store default values for any option in an INI-file in
192 `~/.config/autorandr/settings.ini` in a section `config`. The most useful
193 candidate for doing that is `skip-options`, if you need it.
194
195 ## Advanced usage
196
197 ### Hook scripts
198
199 Three more scripts can be placed in the configuration directory
200 (as defined by the [XDG spec](https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html),
201 usually `~/.config/autorandr` or `~/.autorandr` if you have an old installation
202 for user configuration and `/etc/xdg/autorandr` for system wide configuration):
203
204 - `postswitch` is executed *after* a mode switch has taken place. This can be
205   used to notify window managers or other applications about the switch.
206 - `preswitch` is executed *before* a mode switch takes place.
207 - `postsave` is executed after a profile was stored or altered.
208 - `predetect` is executed before autorandr attempts to run xrandr. 
209
210 These scripts must be executable and can be placed directly in the configuration
211 directory, where they will always be executed, or in the profile subdirectories,
212 where they will only be executed on changes regarding that specific profile.
213
214 Instead (or in addition) to these scripts, you can also place as many executable
215 files as you like in subdirectories called `script_name.d` (e.g. `postswitch.d`).
216
217 If a script with the same name occurs multiple times, user configuration
218 takes precedence over system configuration (as specified by the
219 [XDG spec](https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html))
220 and profile configuration over general configuration.
221
222 As a concrete example, suppose you have the files
223
224 - `/etc/xdg/autorandr/postswitch`
225 - `~/.config/autorandr/postswitch`
226 - `~/.config/autorandr/postswitch.d/notify-herbstluftwm`
227 - `~/.config/autorandr/docked/postswitch`
228
229 and switch from `mobile` to `docked`. Then
230 `~/.config/autorandr/docked/postswitch` is executed, since the profile specific
231 configuration takes precedence, and
232 `~/.config/autorandr/postswitch.d/notify-herbstluftwm` is executed, since
233 it has a unique name.
234
235 If you switch back from `docked` to `mobile`, `~/.config/autorandr/postswitch`
236 is executed instead of the `docked` specific `postswitch`.
237
238 In these scripts, some of autorandr's state is exposed as environment variables
239 prefixed with `AUTORANDR_`, such as:
240 - `AUTORANDR_CURRENT_PROFILE`
241 - `AUTORANDR_CURRENT_PROFILES`
242 - `AUTORANDR_PROFILE_FOLDER`
243 - `AUTORANDR_MONITORS`
244
245 If you experience issues with xrandr being executed too early after connecting
246 a new monitor, then you can use a `predetect` script to delay the execution.
247 Write e.g. `sleep 1` into that file to make autorandr wait a second before
248 running `xrandr`.
249
250 ### Wildcard EDID matching
251
252 The EDID strings in the `~/.config/autorandr/*/setup` files may contain an
253 asterisk to enable wildcard matching: Such EDIDs are matched against connected
254 monitors using the usual file name globbing rules. This can be used to create
255 profiles matching multiple (or any) monitors.
256
257 ## Changelog
258
259 **autorandr 1.10.1**
260 * *2020-05-04* Revert making the launcher the default (fixes #195)
261
262 **autorandr 1.10**
263 * *2020-04-23* Fix hook script execution order to match description from readme
264 * *2020-04-11* Handle negative gamma values (fixes #188)
265 * *2020-04-11* Sort approximate matches in detected profiles by quality of match
266 * *2020-01-31* Handle non-ASCII environment variables (fixes #180)
267 * *2019-12-31* Fix output positioning if the top-left output is not the first
268 * *2019-12-31* Accept negative gamma values (and interpret them as 0)
269 * *2019-12-31* Prefer the X11 launcher over systemd/udev configuration
270
271 **autorandr 1.9**
272
273 * *2019-11-10* Count closed lids as disconnected outputs
274 * *2019-10-05* Do not overwrite existing configurations without `--force`
275 * *2019-08-16* Accept modes that don't match the WWWxHHH pattern
276 * *2019-03-22* Improve bash autocompletion
277 * *2019-03-21* Store CRTC values in configurations
278 * *2019-03-24* Fix handling of recently disconnected outputs (See #128 and #143)
279
280 **autorandr 1.8.1**
281
282 * *2019-03-18* Removed mandb call from Makefile
283
284 **autorandr 1.8**
285
286 * *2019-02-17* Add an X11 daemon that runs autorandr when a display connects (by @rliou92, #127)
287 * *2019-02-17* Replace width=0 check with disconnected to detect disconnected monitors (by @joseph-jones, #139)
288 * *2019-02-17* Fix handling of empty padding (by @jschwab, #138)
289 * *2019-02-17* Add a man page (by @somers-all-the-time, #133)
290
291 **autorandr 1.7**
292
293 * *2018-09-25* Fix FB size computation with rotated screens (by @Janno, #117)
294
295 **autorandr 1.6**
296
297 * *2018-04-19* Bugfix: Do not load default profile unless --change is set
298 * *2018-04-30* Added a `AUTORANDR_MONITORS` variable to hooks (by @bricewge, #106)
299 * *2018-06-29* Fix detection of current configuration if extra monitors are active
300 * *2018-07-11* Bugfix in the latest change: Correctly handle "off" minitors when comparing
301 * *2018-07-19* Do not kill spawned user processes from systemd unit
302 * *2018-07-20* Correctly handle "off" monitors when comparing -- fixup for another bug.
303
304 **autorandr 1.5**
305
306 * *2018-01-03* Add --version
307 * *2018-01-04* Fixed vertical/horizontal/clone-largest virtual profiles
308 * *2018-03-07* Output all non-error messages to stdout instead of stderr
309 * *2018-03-25* Add --detected and --current to filter the profile list output
310 * *2018-03-25* Allow wildcard matching in EDIDs
311
312 **autorandr 1.4**
313
314 * *2017-12-22* Fixed broken virtual profile support
315 * *2017-12-14* Added support for a settings file
316 * *2017-12-14* Added a virtual profile `off`, which disables all screens
317
318 **autorandr 1.3**
319
320 * *2017-11-13* Add a short form for `--load`
321 * *2017-11-21* Fix environment stealing in `--batch` mode (See #87)
322
323 **autorandr 1.2**
324
325 * *2017-07-16* Skip `--panning` unless it is required (See #72)
326 * *2017-10-13* Add `clone-largest` virtual profile
327
328 **autorandr 1.1**
329
330 * *2017-06-07* Call systemctl with `--no-block` from udev rule (See #61)
331 * *2017-01-20* New script hook, `predetect`
332 * *2017-01-18* Accept comments (lines starting with `#`) in config/setup files
333
334 **autorandr 1.0**
335
336 * *2016-12-07* Tag the current code as version 1.0.0; see github issue #54
337 * *2016-10-03* Install a desktop file to `/etc/xdg/autostart` by default
338
339 %package zsh-completion
340 Summary: zsh-completion for autorandr
341 Requires: zsh
342 Requires: %{name}
343 %description zsh-completion
344 This package provides zsh-completion files for autorandr
345
346 %prep
347 %setup -n %{name}-%{version} -n %{name}-%{version}
348 %if %{py_ver} == 3
349 pathfix.py -pni "%{__python3} %{py3_shbang_opts}" ./autorandr.py
350 %else
351 pathfix.py -pni "%{__python2} %{py2_shbang_opts}" ./autorandr.py
352 %endif
353
354 %install
355 make DESTDIR="%{buildroot}" PREFIX=/usr install
356 install -vDm 644 README.md -t "%{buildroot}/usr/share/doc/%{name}/"
357 install -vDm 644 contrib/zsh_completion/_autorandr -t %{buildroot}%{_datarootdir}/zsh/site-functions/
358
359
360 %files
361 %defattr(-,root,root,-)
362 %attr(0644,root,root) %{_unitdir}/autorandr.service
363 %license gpl-3.0.txt 
364 %doc README.md
365 %config(noreplace) %{_sysconfdir}/*
366 %{_bindir}/*
367 %{_mandir}
368 %{_datarootdir}/bash-completion/completions/autorandr
369 %{_udevrulesdir}/40-monitor-hotplug.rules
370
371 %files zsh-completion
372 %{_datarootdir}/zsh/site-functions/_autorandr
373
374 %changelog
375 * Mon Jun 08 2020 Jerzy Drozdz <jerzy.drozdz@jdsieci.pl> - 1.10.1-1
376 - Updated to stable 1.10.1
377 - Added zsh-completion subpackage
378 * Wed May 22 2019 Maciej Sitarz <macieksitarz@wp.pl> - 1.8.1-1
379 - Updated to stable 1.8.1
380 * Fri Sep 28 2018 Maciej Sitarz <macieksitarz@wp.pl> - 1.7-1
381 - Updated to stable 1.7
382 * Thu Jul 19 2018 Maciej Sitarz <macieksitarz@wp.pl> - 1.5-1
383 - Updated to stable 1.5
384 - Changed dest path for systemd service file
385 * Sun Oct 01 2017 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 1.1-2
386 - Added conditionals for pm-utils, compability with Fedora26+
387 - Removed bash-completion from requisites
388 - Removed udev from requisites
389 * Sun Sep 03 2017 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 1.1-1
390 - Update to stable 1.1
391 * Fri Feb 17 2017 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 20170217git-1
392 - Update to master
393 * Wed Jul 6 2016 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 20160706git-1
394 - Set default value of $XDG_CONFIG_DIRS to fulfill the standard
395 * Fri Jul 1 2016 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 20160701git-1.1
396 - fixed running udevadm in post
397 * Fri Jul 1 2016 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 20160701git-1
398 - initial build