]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
finalize changelog for 7904
[dactyl.git] / debian / rules
index 3707167e59378b03e5ad9c065472b5a962549bb1..b324e2016d94a8e060534bf2eceba72ea04974cc 100755 (executable)
@@ -7,6 +7,11 @@ VERSION=$(shell dpkg-parsechangelog | \
 %:
        dh $@ --with xul-ext
 
+# this silliness is needed due to the binary/ directory in the project root
+.PHONY: binary
+binary:
+       dh binary --with xul-ext
+
 override_dh_auto_build:
        make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES='bootstrap.js NEWS' xpi
 
@@ -27,7 +32,7 @@ override_dh_installchangelogs:
                done
 
 UPSTREAM_REPO=../upstream
-UPSTREAM_REVISION=pentadactyl-1.0b6
+UPSTREAM_REVISION=7094
 UPSTREAM_DEST=$(shell pwd)/dactyl.tar.gz
 
 get-orig-source:
@@ -39,6 +44,7 @@ get-orig-source:
        hg --cwd $(UPSTREAM_REPO) update
        hg --cwd $(UPSTREAM_REPO) archive \
                -r $(UPSTREAM_REVISION) -p dactyl \
-               -X .hgtags -X common/javascript.vim \
+               -X .hgtags -X .hgsub -X .hgsubstate -X .hgignore \
+               -X common/javascript.vim \
                -t tgz $(UPSTREAM_DEST)
        test ! -f .hg-repo-created || ( rm -rf $(UPSTREAM_REPO); rm -f .hg-repo-created )