]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
Set MANGLE=chrome (appears to be the default value in various places)
[dactyl.git] / debian / rules
index ec1f85d91c4d40bfb38d1c279782e1c0396bc945..afca4bc31c054045a643b58fa30e4255ca9b5b6f 100755 (executable)
@@ -1,12 +1,14 @@
 #!/usr/bin/make -f
 
 PACKAGES=pentadactyl
+VERSION=$(shell dpkg-parsechangelog | \
+       sed -n -e '/^Version:/ { s/^Version:\s*//; s/[^a-z0-9]/_/g; p }')
 
 %:
        dh $@ --with xul-ext
 
 override_dh_auto_build:
-       make DIRS=$(PACKAGES) MANGLE=dactyl xpi
+       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES=bootstrap.js xpi
 
 override_dh_auto_install:
        for PACKAGE in $(PACKAGES); \
@@ -16,7 +18,7 @@ override_dh_auto_install:
 override_dh_auto_clean:
        make DIRS=$(PACKAGES) clean
        for PACKAGE in $(PACKAGES); \
-               do rm -f $$PACKAGE/dactyl.zip; \
+               do rm -f $$PACKAGE/chrome.zip; \
                done
 
 override_dh_installchangelogs: