]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
Set MANGLE=chrome (appears to be the default value in various places)
[dactyl.git] / debian / rules
index 34d244f08cdc91b7f43841982fea333115c5f7a9..afca4bc31c054045a643b58fa30e4255ca9b5b6f 100755 (executable)
@@ -1,12 +1,14 @@
 #!/usr/bin/make -f
 
 PACKAGES=pentadactyl
+VERSION=$(shell dpkg-parsechangelog | \
+       sed -n -e '/^Version:/ { s/^Version:\s*//; s/[^a-z0-9]/_/g; p }')
 
 %:
        dh $@ --with xul-ext
 
 override_dh_auto_build:
-       make DIRS=$(PACKAGES) MANGLE=dactyl xpi
+       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES=bootstrap.js xpi
 
 override_dh_auto_install:
        for PACKAGE in $(PACKAGES); \
@@ -16,5 +18,10 @@ override_dh_auto_install:
 override_dh_auto_clean:
        make DIRS=$(PACKAGES) clean
        for PACKAGE in $(PACKAGES); \
-               do rm -f $$PACKAGE/dactyl.zip; \
+               do rm -f $$PACKAGE/chrome.zip; \
+               done
+
+override_dh_installchangelogs:
+       for PACKAGE in $(PACKAGES); \
+               do dh_installchangelogs -p xul-ext-$$PACKAGE $$PACKAGE/NEWS; \
                done