]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
1.0~b6-2: Install /usr/share/xul-ext/pentadactyl/NEWS, closes: #637919
[dactyl.git] / debian / rules
index 09d0e21a5d28eede96d0ec1be5db5c5f3e8d2631..3707167e59378b03e5ad9c065472b5a962549bb1 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 
-PACKAGES=pentadactyl
+PACKAGES=pentadactyl # teledactyl melodactyl
 VERSION=$(shell dpkg-parsechangelog | \
        sed -n -e '/^Version:/ { s/^Version:\s*//; s/[^a-z0-9]/_/g; p }')
 
@@ -8,7 +8,7 @@ VERSION=$(shell dpkg-parsechangelog | \
        dh $@ --with xul-ext
 
 override_dh_auto_build:
-       make DIRS=$(PACKAGES) MANGLE=$(VERSION) XPI_FILES=bootstrap.js xpi
+       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES='bootstrap.js NEWS' xpi
 
 override_dh_auto_install:
        for PACKAGE in $(PACKAGES); \
@@ -18,10 +18,27 @@ override_dh_auto_install:
 override_dh_auto_clean:
        make DIRS=$(PACKAGES) clean
        for PACKAGE in $(PACKAGES); \
-               do rm -f $$PACKAGE/$(VERSION).zip; \
+               do rm -f $$PACKAGE/chrome.zip; \
                done
 
 override_dh_installchangelogs:
        for PACKAGE in $(PACKAGES); \
                do dh_installchangelogs -p xul-ext-$$PACKAGE $$PACKAGE/NEWS; \
                done
+
+UPSTREAM_REPO=../upstream
+UPSTREAM_REVISION=pentadactyl-1.0b6
+UPSTREAM_DEST=$(shell pwd)/dactyl.tar.gz
+
+get-orig-source:
+       rm -f .hg-repo-created
+       test -d $(UPSTREAM_REPO) || ( cd `dirname $(UPSTREAM_REPO)` && \
+               hg clone http://dactyl.googlecode.com/hg/ `basename $(UPSTREAM_REPO)` && \
+               touch .hg-repo-created )
+       hg --cwd $(UPSTREAM_REPO) pull
+       hg --cwd $(UPSTREAM_REPO) update
+       hg --cwd $(UPSTREAM_REPO) archive \
+               -r $(UPSTREAM_REVISION) -p dactyl \
+               -X .hgtags -X common/javascript.vim \
+               -t tgz $(UPSTREAM_DEST)
+       test ! -f .hg-repo-created || ( rm -rf $(UPSTREAM_REPO); rm -f .hg-repo-created )