]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
Prepare for 1.0
[dactyl.git] / debian / rules
index a5332172fa282fa32f552f639be7abe752a075ed..200263cd610951de60a2aff730fcdea32a9f6e49 100755 (executable)
@@ -7,6 +7,11 @@ VERSION=$(shell dpkg-parsechangelog | \
 %:
        dh $@ --with xul-ext
 
+# this silliness is needed due to the binary/ directory in the project root
+.PHONY: binary
+binary:
+       dh binary --with xul-ext
+
 override_dh_auto_build:
        make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES='bootstrap.js NEWS' xpi
 
@@ -27,7 +32,7 @@ override_dh_installchangelogs:
                done
 
 UPSTREAM_REPO=../upstream
-UPSTREAM_REVISION=pentadactyl-1.0rc1
+UPSTREAM_REVISION=pentadactyl-1.0
 UPSTREAM_DEST=$(shell pwd)/dactyl.tar.gz
 
 get-orig-source: