]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
Update to upstream r6924
[dactyl.git] / debian / rules
index 0e1a1adbfb74d58a3606fa5b7d322716e61789d9..078f3f62e50e6b25d7c3bf74351b640b34952d22 100755 (executable)
@@ -1,12 +1,19 @@
 #!/usr/bin/make -f
 
-PACKAGES=pentadactyl
+PACKAGES=pentadactyl # teledactyl melodactyl
+VERSION=$(shell dpkg-parsechangelog | \
+       sed -n -e '/^Version:/ { s/^Version:\s*//; s/[^a-z0-9]/_/g; p }')
 
 %:
        dh $@ --with xul-ext
 
+# this silliness is needed due to the binary/ directory in the project root
+.PHONY: binary
+binary:
+       dh binary --with xul-ext
+
 override_dh_auto_build:
-       make DIRS=$(PACKAGES) MANGLE=dactyl XPI_FILES=bootstrap.js xpi
+       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES='bootstrap.js NEWS' xpi
 
 override_dh_auto_install:
        for PACKAGE in $(PACKAGES); \
@@ -16,10 +23,28 @@ override_dh_auto_install:
 override_dh_auto_clean:
        make DIRS=$(PACKAGES) clean
        for PACKAGE in $(PACKAGES); \
-               do rm -f $$PACKAGE/dactyl.zip; \
+               do rm -f $$PACKAGE/chrome.zip; \
                done
 
 override_dh_installchangelogs:
        for PACKAGE in $(PACKAGES); \
                do dh_installchangelogs -p xul-ext-$$PACKAGE $$PACKAGE/NEWS; \
                done
+
+UPSTREAM_REPO=../upstream
+UPSTREAM_REVISION=6924
+UPSTREAM_DEST=$(shell pwd)/dactyl.tar.gz
+
+get-orig-source:
+       rm -f .hg-repo-created
+       test -d $(UPSTREAM_REPO) || ( cd `dirname $(UPSTREAM_REPO)` && \
+               hg clone http://dactyl.googlecode.com/hg/ `basename $(UPSTREAM_REPO)` && \
+               touch .hg-repo-created )
+       hg --cwd $(UPSTREAM_REPO) pull
+       hg --cwd $(UPSTREAM_REPO) update
+       hg --cwd $(UPSTREAM_REPO) archive \
+               -r $(UPSTREAM_REVISION) -p dactyl \
+               -X .hgtags -X .hgsub -X .hgsubstate -X .hgignore \
+               -X common/javascript.vim \
+               -t tgz $(UPSTREAM_DEST)
+       test ! -f .hg-repo-created || ( rm -rf $(UPSTREAM_REPO); rm -f .hg-repo-created )