]> git.donarmstrong.com Git - cran2deb.git/blob - trunk/debian/rules
Added code for a nicely working Debian package.
[cran2deb.git] / trunk / debian / rules
1 #!/usr/bin/make -f
2 #                                                       -*- makefile -*-
3
4 include /usr/share/R/debian/r-cran.mk
5
6 DEB_COMPRESS_EXCLUDE := .pdf
7
8 install/$(package)::
9         # Require a number equal or superior than the R version the package was built with.
10         echo "R:Depends=r-base-core (>= $(shell R --version | head -n1 | perl -ne 'print / +([0-9]\.[0-9]+\.[0-9])/')~)" >> debian/r-$(debRreposname)-$(cranName).substvars