]> git.donarmstrong.com Git - neurodebian.git/blobdiff - survey/Makefile
Merge branch 'master' of git://git.debian.org/pkg-exppsy/neurodebian
[neurodebian.git] / survey / Makefile
index 9ce5fc06e945781dfd3d880c88327a343e21eedb..e817fc8ed400aacc1765ccd58b90db052107c2b7 100644 (file)
@@ -18,7 +18,7 @@ results_snippet.html: results.html
                | tail -n$$(echo "$$(wc -l < results.html) - $$(grep -n '<body>' \
                < results.html | cut -d ':' -f 1,1) - 2" | bc ) > $@
 
-statfigures: oslist.txt swlist.txt datamodlist.txt
+statfigures: oslist.txt swlist.txt datamodlist.txt employer-dd-list.txt position-dd-list.txt
 # create "lockfile'
        @touch $@
        @[ "$$(cat nsubmissions.stamp 2>/dev/null || echo)" != "$$(ls -1 data |wc -l)" ] \
@@ -43,6 +43,12 @@ datamodlist.txt: survey.rst
        grep '"bg_datamod"' survey.rst | sed -e 's/.*name="bg_datamod" value="//' \
                -e 's," />,: ",' -e 's,<br />$$,",' -e 's/ "$$/ "Other"/' > $@
 
+# Generic rule to extract from drop-down selections
+%-dd-list.txt: survey.rst
+       @echo "I: Extracting fields for $* into $@"
+       @sed -n -e '/bg_$*/,/\/tr/p' survey.rst \
+       | sed -ne '/option/s,.*value="\([^"]*\)" *label=\("[^"]*"\)>.*,\1: \2,gp' >| $@
+
 upload: index.html results.html results_snippet.html jquery.form.js survey.css surveycollector.cgi
        rsync -rvzlhp --delete  \
         --exclude='*.txt' --exclude=data --exclude='*.cgi' --exclude=figures \