]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Move .htaccess to /etc/roundcube and use a symlink (Closes: #591369).
[roundcube.git] / debian / rules
index d737fee7c3cd903424f0327f3283bc92e3d8318f..d521ef136760eed3b5dff32b3c7af6c9e9bef90f 100755 (executable)
@@ -1,7 +1,6 @@
 #!/usr/bin/make -f
 
 include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 
@@ -24,9 +23,11 @@ binary-install/roundcube-core::
        # Install config files
        install -m 0640 $(CURDIR)/config/db.inc.php.dist $(CURDIR)/debian/roundcube-core/etc/roundcube/db.inc.php
        install -m 0640 $(CURDIR)/config/main.inc.php.dist $(CURDIR)/debian/roundcube-core/usr/share/roundcube
+       install -m 0640 $(CURDIR)/.htaccess $(CURDIR)/debian/roundcube-core/etc/roundcube/htaccess
        for c in $(CURDIR)/debian/roundcube-core/etc/roundcube/*.php; do \
                dh_link -proundcube-core etc/roundcube/$$(basename $$c) var/lib/roundcube/config/$$(basename $$c) ; \
        done
+       dh_link -proundcube-core etc/roundube/htaccess var/lib/roundcube/.htaccess
 
        # Database related files
        # Install empty tables and updates for each db type
@@ -47,8 +48,8 @@ binary-install/roundcube-core::
        rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/tiny_mce
        dh_link -proundcube-core usr/share/tinymce/www usr/share/roundcube/program/js/tiny_mce
        # Remove jquery as well
-       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/jquery-1.3.min.js
-       dh_link -proundcube-core usr/share/javascript/jquery/jquery.min.js usr/share/roundcube/program/js/jquery-1.3.min.js
+       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/jquery-1.4.min.js
+       dh_link -proundcube-core usr/share/javascript/jquery/jquery.min.js usr/share/roundcube/program/js/jquery-1.4.min.js
 
 $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/% :
        install -d $(CURDIR)/debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)