]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Move .htaccess to /etc/roundcube and use a symlink (Closes: #591369).
[roundcube.git] / debian / rules
index 0b48aa1e895f2c47fef77fef6111f1f63c603e6b..d521ef136760eed3b5dff32b3c7af6c9e9bef90f 100755 (executable)
@@ -1,7 +1,6 @@
 #!/usr/bin/make -f
 
 include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 
@@ -10,6 +9,9 @@ DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 # Then check manually if everything's ok
 
 binary-install/roundcube-core::
+       # Remove plugins
+       rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/plugins
+
        # Symlink all that is in /usr/share/roundcube to /var/lib/roundcube
        find debian/roundcube-core/usr/share/roundcube -maxdepth 1 -mindepth 1 | \
        while read i; do \
@@ -18,32 +20,36 @@ binary-install/roundcube-core::
                  "`echo "$$i" | sed -e s#debian/roundcube-core/usr/share/roundcube/#var/lib/roundcube/#`"; \
                fi \
        done
-       # Install config/db.inc.php.dist
+       # Install config files
        install -m 0640 $(CURDIR)/config/db.inc.php.dist $(CURDIR)/debian/roundcube-core/etc/roundcube/db.inc.php
        install -m 0640 $(CURDIR)/config/main.inc.php.dist $(CURDIR)/debian/roundcube-core/usr/share/roundcube
+       install -m 0640 $(CURDIR)/.htaccess $(CURDIR)/debian/roundcube-core/etc/roundcube/htaccess
+       for c in $(CURDIR)/debian/roundcube-core/etc/roundcube/*.php; do \
+               dh_link -proundcube-core etc/roundcube/$$(basename $$c) var/lib/roundcube/config/$$(basename $$c) ; \
+       done
+       dh_link -proundcube-core etc/roundube/htaccess var/lib/roundcube/.htaccess
 
        # Database related files
        # Install empty tables and updates for each db type
        install -m 0644 $(CURDIR)/SQL/mysql.initial.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/install/mysql
        install -m 0644 $(CURDIR)/SQL/postgres.initial.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/install/pgsql
        install -m 0644 $(CURDIR)/SQL/sqlite.initial.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/install/sqlite
-       # Database upgrade from latest versions
-       install -m 0644 $(CURDIR)/SQL/postgres.update.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/pgsql/0.1.1-1
-       install -m 0644 $(CURDIR)/SQL/mysql.update.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/mysql/0.1.1-1
-       install -m 0644 $(CURDIR)/SQL/sqlite.update.sql $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/sqlite/0.1.1-1
 
        # Old database upgrades
        cp -r $(CURDIR)/debian/sql/* $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/.
 
        # Some files are executable while not being scripts or binary...
-       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program -type f -print0 | xargs -r0 chmod -x
+       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube -type f -print0 | xargs -r0 chmod -x
        # Remove useless file
        rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin/*.sh
        find $(CURDIR)/debian/roundcube-core -name '._*' -print0 | xargs -r0 rm
-       find $(CURDIR)/debian/roundcube-core -name '.htaccess' -print0 | xargs -r0 rm
+       find $(CURDIR)/debian/roundcube-core -name '*.js.src' -print0 | xargs -r0 rm
        # Remove files shipped in tinymce package
        rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/tiny_mce
        dh_link -proundcube-core usr/share/tinymce/www usr/share/roundcube/program/js/tiny_mce
+       # Remove jquery as well
+       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/jquery-1.4.min.js
+       dh_link -proundcube-core usr/share/javascript/jquery/jquery.min.js usr/share/roundcube/program/js/jquery-1.4.min.js
 
 $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/% :
        install -d $(CURDIR)/debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)