]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Ship new configuration files (mimetypes for now, but symlinks should
[roundcube.git] / debian / rules
index f87ce91a461a9b86a22b794fe650a6cb48cd47ce..c76a5097753c32f2ac8f66b6cb9e8484b31fc5d6 100755 (executable)
@@ -21,9 +21,12 @@ binary-install/roundcube-core::
                  "`echo "$$i" | sed -e s#debian/roundcube-core/usr/share/roundcube/#var/lib/roundcube/#`"; \
                fi \
        done
-       # Install config/db.inc.php.dist
+       # Install config files
        install -m 0640 $(CURDIR)/config/db.inc.php.dist $(CURDIR)/debian/roundcube-core/etc/roundcube/db.inc.php
        install -m 0640 $(CURDIR)/config/main.inc.php.dist $(CURDIR)/debian/roundcube-core/usr/share/roundcube
+       for c in $(CURDIR)/debian/roundcube-core/etc/roundcube/*.php; do \
+               dh_link -proundcube-core etc/roundcube/$$(basename $$c) var/lib/roundcube/config/$$(basename $$c) ; \
+       done
 
        # Database related files
        # Install empty tables and updates for each db type