]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
fix clean to remove nscd binary
[unscd.git] / debian / rules
index 59e1de4d90f8570931befd9d1da6119fcd765cb7..b93568908ee54cf7404cd48c5396f9a745679fee 100755 (executable)
@@ -1,13 +1,17 @@
 #!/usr/bin/make -f
 
-%: 
+%:
        dh $@
 
+override_dh_auto_clean:
+       rm -f nscd
+       dh_auto_clean
+
 override_dh_auto_build:
        gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
 
 override_dh_auto_install:
-       $(INSTALL) -d debian/unscd/usr/sbin/
-       $(INSTALL) -t debian/unscd/usr/sbin/ nscd
-       $(INSTALL) -d debian/unscd/etc/
-       $(INSTALL) -m644 -t debian/unscd/etc/ debian/nscd.conf
+       install -d debian/unscd/usr/sbin/
+       install -t debian/unscd/usr/sbin/ nscd
+       install -d debian/unscd/etc/
+       install -m644 -t debian/unscd/etc/ debian/nscd.conf