]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
finalize changelog for 7904
[dactyl.git] / debian / rules
index 3222756784752f1b723945ccecc9da3141130d19..b324e2016d94a8e060534bf2eceba72ea04974cc 100755 (executable)
@@ -7,8 +7,13 @@ VERSION=$(shell dpkg-parsechangelog | \
 %:
        dh $@ --with xul-ext
 
+# this silliness is needed due to the binary/ directory in the project root
+.PHONY: binary
+binary:
+       dh binary --with xul-ext
+
 override_dh_auto_build:
-       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES=bootstrap.js xpi
+       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES='bootstrap.js NEWS' xpi
 
 override_dh_auto_install:
        for PACKAGE in $(PACKAGES); \
@@ -25,3 +30,21 @@ override_dh_installchangelogs:
        for PACKAGE in $(PACKAGES); \
                do dh_installchangelogs -p xul-ext-$$PACKAGE $$PACKAGE/NEWS; \
                done
+
+UPSTREAM_REPO=../upstream
+UPSTREAM_REVISION=7094
+UPSTREAM_DEST=$(shell pwd)/dactyl.tar.gz
+
+get-orig-source:
+       rm -f .hg-repo-created
+       test -d $(UPSTREAM_REPO) || ( cd `dirname $(UPSTREAM_REPO)` && \
+               hg clone http://dactyl.googlecode.com/hg/ `basename $(UPSTREAM_REPO)` && \
+               touch .hg-repo-created )
+       hg --cwd $(UPSTREAM_REPO) pull
+       hg --cwd $(UPSTREAM_REPO) update
+       hg --cwd $(UPSTREAM_REPO) archive \
+               -r $(UPSTREAM_REVISION) -p dactyl \
+               -X .hgtags -X .hgsub -X .hgsubstate -X .hgignore \
+               -X common/javascript.vim \
+               -t tgz $(UPSTREAM_DEST)
+       test ! -f .hg-repo-created || ( rm -rf $(UPSTREAM_REPO); rm -f .hg-repo-created )