]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Fix a spelling error
[roundcube.git] / debian / rules
index a8bf2125fce847016d808980f3a0874a87dfb1a3..acba5c651079bc17f8224ce01d15e3c75f67c923 100755 (executable)
@@ -36,13 +36,17 @@ binary-install/roundcube-core::
        cp -r $(CURDIR)/debian/sql/* $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/.
 
        # Some files are executable while not being scripts or binary...
-       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/localization -type f -print0 | xargs -0 chmod -x
+       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program -type f -print0 | xargs -r0 chmod -x
        # Remove useless file
-       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/lib/magic
-       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin/msgimport
+       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin/*.sh
+       find $(CURDIR)/debian/roundcube-core -name '._*' -print0 | xargs -r0 rm
        # Remove files shipped in tinymce package
        rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/tiny_mce
-       dh_link -proundcube-core usr/share/tinymce2/www usr/share/roundcube/program/js/tiny_mce
+       dh_link -proundcube-core usr/share/tinymce/www usr/share/roundcube/program/js/tiny_mce
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/% :
+       install -d $(CURDIR)/debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)
+       install -m 644 $(CURDIR)/debian/bug.control $(CURDIR)/debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/control
 
 clean::
        debconf-updatepo