]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Let systemctl help find the man page
[unscd.git] / debian / rules
index d45f9e4fc6ed610aefb2314a4fd0663d7d35bc18..a5b6f487e82d013d9ddc4ff9f11cf38c806cc989 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
 %:
        dh $@ --with systemd
 
@@ -8,7 +10,7 @@ override_dh_auto_clean:
        dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       gcc $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
        help2man --name 'nscd which does not hang' \
                --include debian/help2man \
                --no-info \
@@ -20,3 +22,6 @@ override_dh_auto_install:
        install -t debian/unscd/usr/sbin/ nscd
        install -d debian/unscd/etc/
        install -m644 -t debian/unscd/etc/ debian/nscd.conf
+
+override_dh_systemd_start:
+       dh_systemd_start --restart-after-upgrade --no-stop-on-upgrade