]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Add a patch to avoid duplicate boundaries in headers when adding an
[roundcube.git] / debian / rules
index c76a5097753c32f2ac8f66b6cb9e8484b31fc5d6..92d44a21ef4f992225bfbe47e0847fe989064256 100755 (executable)
@@ -1,7 +1,6 @@
 #!/usr/bin/make -f
 
 include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 
@@ -38,11 +37,11 @@ binary-install/roundcube-core::
        cp -r $(CURDIR)/debian/sql/* $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/.
 
        # Some files are executable while not being scripts or binary...
-       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program -type f -print0 | xargs -r0 chmod -x
+       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube -type f -print0 | xargs -r0 chmod -x
        # Remove useless file
        rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin/*.sh
+       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin/decrypt.php
        find $(CURDIR)/debian/roundcube-core -name '._*' -print0 | xargs -r0 rm
-       find $(CURDIR)/debian/roundcube-core -name '.htaccess' -print0 | xargs -r0 rm
        find $(CURDIR)/debian/roundcube-core -name '*.js.src' -print0 | xargs -r0 rm
        # Remove files shipped in tinymce package
        rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/tiny_mce