]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Add a patch to avoid duplicate boundaries in headers when adding an
[roundcube.git] / debian / rules
index 0d9aead33d7a4de49f3d36441ecc08b53043a8fc..92d44a21ef4f992225bfbe47e0847fe989064256 100755 (executable)
@@ -1,7 +1,6 @@
 #!/usr/bin/make -f
 
 include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 
@@ -10,6 +9,9 @@ DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 # Then check manually if everything's ok
 
 binary-install/roundcube-core::
+       # Remove plugins
+       rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/plugins
+
        # Symlink all that is in /usr/share/roundcube to /var/lib/roundcube
        find debian/roundcube-core/usr/share/roundcube -maxdepth 1 -mindepth 1 | \
        while read i; do \
@@ -18,9 +20,12 @@ binary-install/roundcube-core::
                  "`echo "$$i" | sed -e s#debian/roundcube-core/usr/share/roundcube/#var/lib/roundcube/#`"; \
                fi \
        done
-       # Install config/db.inc.php.dist
+       # Install config files
        install -m 0640 $(CURDIR)/config/db.inc.php.dist $(CURDIR)/debian/roundcube-core/etc/roundcube/db.inc.php
        install -m 0640 $(CURDIR)/config/main.inc.php.dist $(CURDIR)/debian/roundcube-core/usr/share/roundcube
+       for c in $(CURDIR)/debian/roundcube-core/etc/roundcube/*.php; do \
+               dh_link -proundcube-core etc/roundcube/$$(basename $$c) var/lib/roundcube/config/$$(basename $$c) ; \
+       done
 
        # Database related files
        # Install empty tables and updates for each db type
@@ -32,11 +37,11 @@ binary-install/roundcube-core::
        cp -r $(CURDIR)/debian/sql/* $(CURDIR)/debian/roundcube-core/usr/share/dbconfig-common/data/roundcube/upgrade/.
 
        # Some files are executable while not being scripts or binary...
-       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program -type f -print0 | xargs -r0 chmod -x
+       find $(CURDIR)/debian/roundcube-core/usr/share/roundcube -type f -print0 | xargs -r0 chmod -x
        # Remove useless file
        rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin/*.sh
+       rm $(CURDIR)/debian/roundcube-core/usr/share/roundcube/bin/decrypt.php
        find $(CURDIR)/debian/roundcube-core -name '._*' -print0 | xargs -r0 rm
-       find $(CURDIR)/debian/roundcube-core -name '.htaccess' -print0 | xargs -r0 rm
        find $(CURDIR)/debian/roundcube-core -name '*.js.src' -print0 | xargs -r0 rm
        # Remove files shipped in tinymce package
        rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/program/js/tiny_mce