]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
Work around the binary/ directory by adding an extra target
[dactyl.git] / debian / rules
index c084bdc09304a58e9b69a0de87e28fc22c138958..92346af8a744a2baa8dc5ab035f4ce9a8cd084a5 100755 (executable)
@@ -7,8 +7,13 @@ VERSION=$(shell dpkg-parsechangelog | \
 %:
        dh $@ --with xul-ext
 
+# this silliness is needed due to the binary/ directory in the project root
+.PHONY: binary
+binary:
+       dh binary --with xul-ext
+
 override_dh_auto_build:
-       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES=bootstrap.js xpi
+       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES='bootstrap.js NEWS' xpi
 
 override_dh_auto_install:
        for PACKAGE in $(PACKAGES); \
@@ -27,7 +32,7 @@ override_dh_installchangelogs:
                done
 
 UPSTREAM_REPO=../upstream
-UPSTREAM_REVISION=pentadactyl-1.0b6
+UPSTREAM_REVISION=pentadactyl-1.0rc1
 UPSTREAM_DEST=$(shell pwd)/dactyl.tar.gz
 
 get-orig-source: