]> git.donarmstrong.com Git - perltidy.git/blobdiff - debian/rules
switch debhelper to compatibility 10
[perltidy.git] / debian / rules
index f6289a72f7d44941403717b0bcbfe5e964f2ab4b..6a7c69c437064d130cf15dddafaf036c538aadbe 100755 (executable)
@@ -1,88 +1,7 @@
 #!/usr/bin/make -f
-#-*- makefile -*-
-# Made with the aid of dh_make, by Craig Small
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-# Some lines taken from debmake, by Christoph Lameter.
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-export DH_COMPAT=3
+%:
+       dh $@
 
-PACKAGE=$(shell dh_listpackages)
-
-ifndef PERL
-PERL = /usr/bin/perl
-endif
-
-ifndef DESTDIR
-DESTDIR=..
-endif
-TMP     =`pwd`/debian/$(PACKAGE)
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       
-       # Add here commands to compile the package.
-       $(PERL) Makefile.PL INSTALLDIRS=vendor
-       $(MAKE) OPTIMIZE="-O2 -g -Wall"
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) realclean
-
-       dh_clean
-
-install: 
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       # Add here commands to install the package into debian/tmp.
-       #$(MAKE) install DESTDIR=`pwd`/debian/tmp
-       $(MAKE) install PREFIX=$(TMP)/usr
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
-# Build architecture-independent files here.
-binary-indep: build install
-#      dh_testversion
-       dh_testdir
-       dh_testroot
-       dh_installdocs BUGS TODO README examples/README docs/README
-       dh_installexamples
-       dh_installmenu
-#      dh_installemacsen
-#      dh_installinit
-       dh_installcron
-       dh_installman
-#      dh_undocumented
-       dh_installchangelogs CHANGES
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-       dh_perl 
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb --destdir=$(DESTDIR)
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+override_dh_installexamples: 
+       dh_installexamples examples/*