]> git.donarmstrong.com Git - dactyl.git/blobdiff - debian/rules
debian/rules: Make it a little clearer why the for loops are there
[dactyl.git] / debian / rules
index 0e1a1adbfb74d58a3606fa5b7d322716e61789d9..3222756784752f1b723945ccecc9da3141130d19 100755 (executable)
@@ -1,12 +1,14 @@
 #!/usr/bin/make -f
 
-PACKAGES=pentadactyl
+PACKAGES=pentadactyl # teledactyl melodactyl
+VERSION=$(shell dpkg-parsechangelog | \
+       sed -n -e '/^Version:/ { s/^Version:\s*//; s/[^a-z0-9]/_/g; p }')
 
 %:
        dh $@ --with xul-ext
 
 override_dh_auto_build:
-       make DIRS=$(PACKAGES) MANGLE=dactyl XPI_FILES=bootstrap.js xpi
+       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES=bootstrap.js xpi
 
 override_dh_auto_install:
        for PACKAGE in $(PACKAGES); \
@@ -16,7 +18,7 @@ override_dh_auto_install:
 override_dh_auto_clean:
        make DIRS=$(PACKAGES) clean
        for PACKAGE in $(PACKAGES); \
-               do rm -f $$PACKAGE/dactyl.zip; \
+               do rm -f $$PACKAGE/chrome.zip; \
                done
 
 override_dh_installchangelogs: