]> git.donarmstrong.com Git - debbugs.git/blobdiff - debian/rules
Fix lintian issues: debian-rules-missing-recommended-target build-arch, debian-rules...
[debbugs.git] / debian / rules
index df649af5393756617b5143a3ccaf3e350e907b45..260659f5812288e1ea6f55d94e243d40000a66d4 100755 (executable)
@@ -10,12 +10,18 @@ DEST_DIR := $(CURDIR)/debian/tmp
 PERL ?= /usr/bin/perl
 
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch:
+# nothing to do, as there aren't any architecture-dependent packages
+
+build-indep: build-stamp
+
 build-stamp:
 # Call the test suite
        $(PERL) Makefile.PL INSTALLDIRS=vendor
        $(MAKE) -f Makefile.perl
-#      $(MAKE) test
+       $(MAKE) test
        touch $@
 
 clean:
@@ -26,7 +32,7 @@ clean:
                $(MAKE) -f Makefile.perl clean; \
        fi;
        #something to remove all trace and *.trace files?
-       rm -f debbugs.trace
+       rm -f debbugs.trace Makefile.perl.old
        dh_clean
 
 install: install-stamp