]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
* Also provide documents in single-file HTML format.
[debian/debian-policy.git] / debian / rules
index 4fa4518f6025ca9d00892df9815d627cd4435bfc..07e635e68cd5cb537c4349d18e7895d5b0b5be29 100755 (executable)
@@ -55,6 +55,7 @@ FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
                  version.ent upgrading-checklist.txt \
                  $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
+                  $(SGML_FILES:=-1.html) \
                  policy.pdf.gz policy.ps.gz \
                  debconf_specification.xml.tar.gz \
                  policy.pdf policy.ps policy.txt policy. \
@@ -73,6 +74,7 @@ all build: stamp-build
 stamp-build: version.ent $(sanitycheck)
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
+                $(SGML_FILES:=-1.html) \
                $(SGML_FILES:=.txt.gz) \
                policy.ps.gz policy.pdf.gz
        links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
@@ -139,6 +141,9 @@ stamp-policy:  build $(sanitycheck)
        for file in $(SGML_FILES); do \
          tar -C $(DOCDIR) -zxf $$file.html.tar.gz; \
        done
+       for file in $(SGML_FILES); do \
+         $(install_file) $${file}-1.html $(DOCDIR); \
+       done
        $(install_file)     $(FHS_HTML)   $(DOCDIR)/fhs
        @set -ex; \
        cd debian/tmp; \