]> git.donarmstrong.com Git - debbugs.git/blobdiff - debian/changelog
merge back in source merges to fix the broken repository
[debbugs.git] / debian / changelog
index f1f33954dc84e83aaaf24c60a46123c131bdf3cb..7929ba2e6ba1c9a137a492c5cfe9f5da8b37b975 100644 (file)
@@ -11,9 +11,116 @@ debbugs (2.4.2) UNRELEASED; urgency=low
       acknowledgements.
     - Document how to deliver mail to debbugs via procmail and SpamAssassin.
     - Implement new .status format that's extensible and easier to read; it
-      now lives in .db rather than .status. Use debbugs-upgradestatus to
-      convert existing bug databases.
+      now lives in .summary rather than .status. Use debbugs-upgradestatus
+      to convert existing bug databases.
+    - Implement bug ownership, with new 'owner' and 'noowner' commands and
+      Owner: pseudo-header (closes: #133453).
+    - Install Debian configuration in the binary package's examples
+      directory (closes: #222118).
+    - New standalone SpamAssassin queue runner, spamscan.
+    - Allow # prefix on bug numbers in 'merge' command.
+    - Fix some ordering issues in old-style package pages and summaries.
+    - Add X-$gProject-PR-Message: headers to all mails sent by service.
+    - debbugsconfig creates required directories in $gSpoolDir
+      (closes: #222077).
+    - Decode RFC1522 mail headers for display in the web interface.
+      bugreport.cgi and pkgreport.cgi now output UTF-8.
+    - Properly support multiple submitter addresses on a single bug.
+    - Add a number of extra htmlsanit() calls to prevent cross-site
+      scripting attacks.
 
+  * Adam Heath:
+    - Rewrite filtering in cgi's common.pl, to make it completely generic.
+      Filtering can now work against any field.
+    - Rewrite grouping logic in cgi's common.pl, to make it completely
+      generic.  There is now no longer 2 nested loops, to do the grouping.
+      This makes adding new grouping levels simpler for the future.
+    - Add in a Table of Contents to pkgreport.cgi.
+    - Display how long until a resolved bug will be archived in
+      pkgreport.cgi.
+    - Add user-agent detection.  This currently doesn't change anything,
+      however.
+    - Add options show_list_(head|foot)er.
+
+  * Don Armstrong:
+
+    - Don't remove the maintainer address if the message was sent by the
+      maintainer and we're submitting to maintonly (closes: #140061)
+    - Use uri_escape to escape URI's before sending them back out so the
+      name of the file doesn't munge the query string. [#301606 pt. 1]
+    - call decode_rfc1522 on the filename returned so that encoded
+      filenames get decoded to something "reasonable." (closes: #301606)
+    - We now require URI::Escape
+    - Added apache.conf to examples, which is a sample apache
+      configuration file which implements the rewrite rules that are
+      currently used on bugs.debian.org. (closes: #222264)
+    - Change spamscan.in to work with SA 3.0; This is an incompatible
+      change with SA 2.6, and as such, we now Suggests: spamassassin 
+      (>=3.0) (closes: #290501)
+    - Update MTA to exim4 (closes: #228597) and add instructions on using
+      exim 4 (thanks to Marc Haber) (closes: #248335)
+    - Added per bug subscription support to debbugs, which relies on an
+      external MLM to actually deal with the requests; currently works with
+      eoc and sends messages to bugnum\@$gListDomain. (closes: #34071)
+    - Change bugreport.cgi to use Debbugs::Log and greately simplify the
+      process of outputing the bug log.
+    - All RFC1522 subject lines are decoded, both in the html information
+      and the message headers. All messages are converted to UTF-8 whereever
+      possible; all bugreport.cgi pages are now completely in UTF-8 to the
+      degree possible using Encode.pm (closes: #46848,#238984)
+    - Add a convert_to_utf8 function to Debbugs::Mime to make the above
+      possible; abstracts functionality that was already present in the
+      decode_rfc1522 fucntionality.
+    - Individual messages can now be downloaded from each bug report
+      (closes: #95373)
+    - Uninteresting headers are now hidden by default, can be renabled
+      with &trim=no (closes: #188561)
+    - Fix postfix instructions in README.mail (thanks to Jeff Teunissen)
+      (closes: #134166)
+    - Display old severity when changing severity (closes: #196947)
+    - All messages that originate from the BTS and either go to .log files
+      or out to users are now properly RFC1522 encoded. (closes: #306068)
+    - Add links to cloned bugs (closes: #217960) and forwarded records
+      that look like urls in the html records output by bugreport.cgi.
+    - Things that look like urls in message bodies are now linked
+      (closes: #168962)
+    - Add Debbugs::Mail module that has two important functions:
+      send_mail_message and encode_headers. All mail handling in service.in
+      and process.in now uses send_mail_message to send mail messages which
+      tries as hard as possible to send a message; if it fails, only
+      warnings are returned. This fixes bad addresses causing sendmail to
+      exit and destroying the bug log. (closes: #191306)
+    - Add rudimentary Test::More modules for testing Debbugs::Mime and
+      Debbugs::Mail.
+    - Allow X-debbugs-* to be set in pseudo headers. (closes: #179340)
+    - Obey X-Debbugs-No-Ack in control@ messages. (closes: #201825)
+    - Allow forwarded: and owner to be set at submit@ time.
+      (closes:#128320)
+    - Fix example rewrite rules to allow for #1234 and foo+bar@baz.com
+      (closes: #321925)
+    - Output proper charset for attachments (closes: #335813)
+    - Use MIME encodings to attach messages in close and done.
+      (closes: #136654)
+    - Add a forcemerge command to service.in to allow forcibly merging
+      bugs which are in the same package. (closes: #286792)
+    - Make all packages lowercase to support packages with uppercase
+      names, even though that's insane. (closes: #67067)
+    - Change acknowledged to close (closes: #61341) and indicate who
+      actually closed the bug (closes: #355968, #132274)
+    - Fix the documentation of clone to indicate that you need at least
+      one newID (closes: #276747)
+    - Use create_mime_message to send all of the mails which may contain
+      UTF8 material. (closes: #364026)
+    - Add links to Closes: text for closed bugs. (closes: #320986)
+    - Add X-$gProject-PR-Source: line (closes: #219230)
+    - Use the %cats data structure properly in pkgreport.cgi
+      (closes: #367514)  
+    - Document nnn.*@foobar addresses (closes: #188670)
+    - Support cloned bugs in control blocking (closes: #337329)
+    - Indicate which bugs are blocked after blocking (closes: #367496)
+    - Obey package for usertags (closes: #376528)
+
+  
  -- Colin Watson <cjwatson@debian.org>  Fri, 20 Jun 2003 18:57:25 +0100
 
 debbugs (2.4.1) unstable; urgency=low