]> git.donarmstrong.com Git - debbugs.git/blobdiff - debian/changelog
[project @ 2005-07-30 03:22:36 by don]
[debbugs.git] / debian / changelog
index 3ef2a2214d4688736ef553869e169a176545df50..5c9aff723a092ee544cfc18de8d9640743065705 100644 (file)
@@ -1,4 +1,120 @@
-debbugs (2.4-1) experimental; urgency=medium
+debbugs (2.4.2) UNRELEASED; urgency=low
+
+  * Anthony Towns:
+    - Add "package" command to service (control@) to limit the bugs that
+      the following commands apply to.
+
+  * Colin Watson:
+    - Add (slightly) fancy CGI decoding of message/* MIME types.
+    - CGI scripts now support multiple maintainers for a single package.
+    - Add support for an X-Debbugs-No-Ack: mail header to suppress
+      acknowledgements.
+    - Document how to deliver mail to debbugs via procmail and SpamAssassin.
+    - Implement new .status format that's extensible and easier to read; it
+      now lives in .summary rather than .status. Use debbugs-upgradestatus
+      to convert existing bug databases.
+    - Implement bug ownership, with new 'owner' and 'noowner' commands and
+      Owner: pseudo-header (closes: #133453).
+    - Install Debian configuration in the binary package's examples
+      directory (closes: #222118).
+    - New standalone SpamAssassin queue runner, spamscan.
+    - Allow # prefix on bug numbers in 'merge' command.
+    - Fix some ordering issues in old-style package pages and summaries.
+    - Add X-$gProject-PR-Message: headers to all mails sent by service.
+    - debbugsconfig creates required directories in $gSpoolDir
+      (closes: #222077).
+    - Decode RFC1522 mail headers for display in the web interface.
+      bugreport.cgi and pkgreport.cgi now output UTF-8.
+    - Properly support multiple submitter addresses on a single bug.
+
+  * Adam Heath:
+    - Rewrite filtering in cgi's common.pl, to make it completely generic.
+      Filtering can now work against any field.
+    - Rewrite grouping logic in cgi's common.pl, to make it completely
+      generic.  There is now no longer 2 nested loops, to do the grouping.
+      This makes adding new grouping levels simpler for the future.
+    - Add in a Table of Contents to pkgreport.cgi.
+    - Display how long until a resolved bug will be archived in
+      pkgreport.cgi.
+    - Add user-agent detection.  This currently doesn't change anything,
+      however.
+    - Add options show_list_(head|foot)er.
+
+  * Don Armstrong:
+
+    - Don't remove the maintainer address if the message was sent by the
+      maintainer and we're submitting to maintonly (closes: #140061)
+    - Use uri_escape to escape URI's before sending them back out so the
+      name of the file doesn't munge the query string. [#301606 pt. 1]
+    - call decode_rfc1522 on the filename returned so that encoded
+      filenames get decoded to something "reasonable." (closes: #301606)
+    - We now require URI::Escape
+    - Added apache.conf to examples, which is a sample apache
+      configuration file which implements the rewrite rules that are
+      currently used on bugs.debian.org. (closes: #222264)
+    - Change spamscan.in to work with SA 3.0; This is an incompatible
+      change with SA 2.6, and as such, we now Suggests: spamassassin 
+      (>=3.0) (closes: #290501)
+    - Update MTA to exim4 (closes: #228597) and add instructions on using
+      exim 4 (thanks to Marc Haber) (closes: #248335)
+    - Added per bug subscription support to debbugs, which relies on an
+      external MLM to actually deal with the requests; currently works with
+      eoc and sends messages to bugnum\@$gListDomain. (closes: #34071)
+    - Change bugreport.cgi to use Debbugs::Log and greately simplify the
+      process of outputing the bug log.
+    - All RFC1522 subject lines are decoded, both in the html information
+      and the message headers. All messages are converted to UTF-8 whereever
+      possible; all bugreport.cgi pages are now completely in UTF-8 to the
+      degree possible using Encode.pm (closes: #46848,#238984)
+    - Add a convert_to_utf8 function to Debbugs::Mime to make the above
+      possible; abstracts functionality that was already present in the
+      decode_rfc1522 fucntionality.
+    - Individual messages can now be downloaded from each bug report
+      (closes: #95373)
+    - Uninteresting headers are now hidden by default, can be renabled
+      with &trim=no (closes: #188561)
+    - Fix postfix instructions in README.mail (thanks to Jeff Teunissen)
+      (closes: #134166)
+    - Display old severity when changing severity (closes: #196947)
+    - All messages that originate from the BTS and either go to .log files
+      or out to users are now properly RFC1522 encoded. (closes: #306068)
+
+ -- Colin Watson <cjwatson@debian.org>  Fri, 20 Jun 2003 18:57:25 +0100
+
+debbugs (2.4.1) unstable; urgency=low
+
+  * Colin Watson:
+    - Exit the CGI scripts straight away if the HTTP method is HEAD, to save
+      pointless work.
+    - Display pending+fixed bugs as "fixed in NMU", not "pending upload".
+    - Add a man page for debbugsconfig.
+    - Report original tags when changing them, closes: #170630.
+    - Add missing <ul></ul> tags to db2html's output, closes: #50746.
+    - Add a 'submitter' command to service, based on a patch by Matt Kraai.
+    - Remove the final use of cgi-lib.pl, so it's gone. Remove copyright
+      notices that were there due to using it.
+    - Accept ';' as well as '&' as a CGI argument separator.
+    - db2html now works with the new hashed database layout.
+    - Disable the fixed severity in favour of the tag.
+    - MIME-encoded messages to bugs are displayed in decoded form on the web
+      interface (unless the "mime=no" parameter is used), closes: #136114.
+    - Add facility to search by tag.
+    - Fix rebuild script and add it to the example crontab, closes: #139696.
+    - Silence postinst warning if spool/db doesn't exist, closes: #194892.
+    - Clean up the definition and use of $gCGIDomain, closes: #139697.
+  * Adam Heath:
+    - Convert all code to use global read/write functions, instead of having
+      it duplicated everywhere.
+    - Trim trailing whitespace from pseudoheader values.  Closes: #153590.
+    - Warn when reassigning to an unknown package.  Closes: #60595.
+  * Josip Rodin:
+    - Added a terse=yes mode for bugreport.cgi, possibly useful for
+      monstrously long bugs.
+    - Purged needless date(1) forks, replaced with strftime.
+
+ -- Colin Watson <cjwatson@debian.org>  Fri,  6 Jun 2003 09:25:30 +0100
+
+debbugs (2.4) experimental; urgency=low
 
   * Updating the package with what's in CVS, even though this might
     completely break things for people who've been using the previous also
@@ -41,10 +157,53 @@ debbugs (2.4-1) experimental; urgency=medium
     an package with no maintainer is referenced. [Adam]
   * processall locks 'incoming-cleaner' before starting, so we don't have
     multiple copies of it running at the same time. [Adam]
-  * Added myself to the Uploaders: field. [Josip]
+  * Sort bugs tagged 'pending' as 'pending upload', between 'forwarded' and
+    'fixed'. [Adam]
+  * Add support for searching by source package.  pkgreport.cgi takes src=,
+    and both pkgreport.cgi and bugreport.cgi have enhanced HTML headers now.
+    [Adam]
+  * Add support in the CGIs for:
+    * 'raw' sorting. This does no grouping based on status or severity, and
+      just lists bugs in number order.
+    * reversing the order that bugs are displayed. This does not affect
+      severity or status ordering.
+    * inclusions/exclusions of status and severity. Also, support reverse
+      sorting of the above.
+  * Make it possible to ban people from control@bugs. [Anthony]
+  * Don't lie about missing Subject:s being an RFC822 violation, because
+    they aren't. [Anthony, Josip]
+  * Added preliminary support for ###-request. [Adam]
+  * Added preliminary fast indexing support. [Adam/Anthony (?)]
+  * Added preliminary support for CC:ing <src>@packages.qa.debian.org.
+    [Anthony]
+  * Added preliminary cloning support. [Anthony]
+  * Link to submitter's web page, patch from Matt Kraai. [Josip]
+  * The autoconfig thing in the description is gone, closes: #124537.
+  * Fix viewing archived bugs by source package, closes: #121082, #146484.
+    [Colin]
+  * Depends: libmailtools-perl rather than mailtools, closes: #113028.
+  * Add MIME support to process and service, and depend on libmime-perl as a
+    result, closes: #36813. [Colin]
+  * Trim Bug#12345: from the Subject:, not "Bug#12345: [", closes: #78123.
+    [Anthony]
+  * Be more careful about loop detection, closes: #113514. [Adam, Colin]
+  * Relax the syntax for 'tags' slightly, since people seem to use it that
+    way accidentally a lot, closes: #96164. [Colin]
+  * Give better feedback from pkgreport.cgi when querying a non-existent
+    package name, closes: #93433. [Colin]
+  * Remove support for -fixed address from receive, since nothing else
+    supports it. [Colin]
+  * Prevent people from reading the first line of arbitrary files through
+    bugreport.cgi, thanks to Max <rusmir@tula.net>. [Colin]
+  * Add working-for-me instructions for exim setup on non-dedicated sites,
+    together with Chad Miller's suggestions, closes: #78688. [Colin]
+  * Fix a few typos, closes: #146745, #152751.
+  * Update the copyright file with the current list of maintainers and a
+    pointer to ViewCVS.
+  * Remove lynx-cfg, and use 'lynx -cfg=/dev/null' instead. [Colin]
   * Various other things, not worth mentioning here.
 
- -- Josip Rodin <jrodin@jagor.srce.hr>  UNRELEASED
+ -- Colin Watson <cjwatson@debian.org>  Sun, 17 Nov 2002 17:54:49 +0000
 
 debbugs (2.3-4) unstable; urgency=low
 
@@ -55,8 +214,14 @@ debbugs (2.3-4) unstable; urgency=low
   * Fixed the nextnumber misplacement (it should be in spool dir, not config
     dir), and added a note about running debbugsconfig after changes to
     config file, thanks to Rob for the hints. [Josip]
+  * Changed Maintainer: to point to debian-debbugs. Added myself to
+    Uploaders:. [Josip]
+  * Fixed Lintian errors: file-in-etc-not-marked-as-conffile (except
+    for lynx-cfg which is a gross hack anyway),
+    virtual-package-depends-without-real-package-depends,
+    debian-changelog-file-contains-user-emacs-settings.
 
- -- Josip Rodin <jrodin@jagor.srce.hr>  Sat, 27 Jan 2001 23:20:06 +0100
+ -- Josip Rodin <jrodin@jagor.srce.hr>  Thu,  7 Feb 2002 17:30:17 +0100
 
 debbugs (2.3-3) unstable; urgency=low
 
@@ -198,8 +363,3 @@ debbugs (1.0-1) unstable; urgency=low
   * Initial Release.
 
  -- Darren Benham <gecko@debian.org>  Thu, 21 Jan 1999 20:55:51 -0800
-
-Local variables:
-mode: debian-changelog
-add-log-mailing-address: "gecko@debian.org"
-End: