]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: mirmon and refresh (the one to be called hourly from cron) Makefile rules
[neurodebian.git] / Makefile
index b18c3107a176a98b3bedf619db7ae03a430084d6..cf3899471a2864bdf335316887c9c980c5005fd0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,10 @@
 WWW_UPLOAD_URI = ../www
 WWW_DIR = build/html/
 
-all: updatedb upload-website
+# Lentghy one due to updatedb
+all: updatedb upload-website mirmon
+# Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
+refresh: upload-website-stamp mirmon
 
 
 pics:
@@ -10,7 +13,7 @@ pics:
 
 
 html: pics source
-       rsync -rvlhp sphinx/ build/src
+       rsync -rvlhpt sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
@@ -20,7 +23,7 @@ html: pics source
 
 
 clean:
-       -rm html-stamp source-stamp
+       -rm html-stamp source-stamp upload-website-stamp
        $(MAKE) -C artwork clean
 
 
@@ -30,7 +33,7 @@ distclean: clean
 
 source: source-stamp
 source-stamp: build/db.db
-       PYTHONPATH=. python neurodebian/dde.py \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
@@ -53,7 +56,7 @@ updatedb: removedb removecache build/db.db
 
 build/db.db:
        mkdir -p build
-       PYTHONPATH=. python neurodebian/dde.py \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
@@ -64,6 +67,16 @@ upload-website: html
        rsync -rvzlhp --delete \
         --exclude=debian --exclude=debian-local --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       : # Touch stamp here so we get it updated on every upload
+       touch $@-stamp
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html
+# call upload iff .git/index was modified, i.e. new changes got pulled in
+upload-website-stamp: .git/index
+       $(MAKE) upload-website
+
+mirmon:
+       # update and generate mirrors report
+       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon