]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: mirmon and refresh (the one to be called hourly from cron) Makefile rules
[neurodebian.git] / Makefile
index afa071989576feab5e79837313428fbb48bf8ba7..cf3899471a2864bdf335316887c9c980c5005fd0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,15 +2,18 @@
 WWW_UPLOAD_URI = ../www
 WWW_DIR = build/html/
 
-all: updatedb upload-website
+# Lentghy one due to updatedb
+all: updatedb upload-website mirmon
+# Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
+refresh: upload-website-stamp mirmon
 
 
 pics:
        $(MAKE) -C artwork
 
 
-html: pics source
-       rsync -rvlhp sphinx/ build/src
+html: pics source
+       rsync -rvlhpt sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
@@ -71,5 +74,9 @@ upload-website: html
 upload-website-stamp: .git/index
        $(MAKE) upload-website
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html
+mirmon:
+       # update and generate mirrors report
+       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon