]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: mirmon and refresh (the one to be called hourly from cron) Makefile rules
[neurodebian.git] / Makefile
index 2753e678b75c82887aa6ccd36344fff507aefb78..cf3899471a2864bdf335316887c9c980c5005fd0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,56 +1,82 @@
-# old location
-WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
-# brand new fancy one
 #WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
-WWW_DIR = build/html
+WWW_UPLOAD_URI = ../www
+WWW_DIR = build/html/
 
-all: html
-
-prep:
-       if [ ! -d build ]; then mkdir build; fi
-       rsync -rvlhp sphinx/ build/src
+# Lentghy one due to updatedb
+all: updatedb upload-website mirmon
+# Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
+refresh: upload-website-stamp mirmon
 
 
 pics:
        $(MAKE) -C artwork
 
 
-html: html-stamp
-html-stamp: pics prep source
-       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
-       touch $@
+html: pics source
+       rsync -rvlhpt sphinx/ build/src
+       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
+       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
+       cp -r build/src/lists $(WWW_DIR)/
+       cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
 
 
 clean:
-       -rm -rf build
-       -rm html-stamp source-stamp
+       -rm html-stamp source-stamp upload-website-stamp
        $(MAKE) -C artwork clean
 
 
-
 distclean: clean
-       -rm -rf cache
+       -rm -rf build
 
 
 source: source-stamp
 source-stamp: build/db.db
-       tools/reblender generate \
-               --cfg debneuro.cfg \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
-               --pkgaddenum pkgs
+               --pkgaddenum pkgs \
+               --extracts /home/www/neuro.debian.net/www/debian/extracts \
+               commandisirrelevant
        rm -f html-stamp
        touch $@
 
 
+removecache:
+       -rm -rf build/cache
+
+removedb:
+       -rm -f build/db.db
+
+
+updatedb: removedb removecache build/db.db
+
+
 build/db.db:
        mkdir -p build
-       tools/reblender refreshdb \
-               --cfg debneuro.cfg \
-               --db build/db.db
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
+               --db build/db.db \
+               updatedb
+       -rm -f source-stamp
 
 
 upload-website: html
-       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       : # Touch stamp here so we get it updated on every upload
+       touch $@-stamp
+
+# call upload iff .git/index was modified, i.e. new changes got pulled in
+upload-website-stamp: .git/index
+       $(MAKE) upload-website
+
+mirmon:
+       # update and generate mirrors report
+       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon
 
-.PHONY: prep