]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Force cache update in updatedb
[neurodebian.git] / Makefile
index f3d0e1dea76718829370338b53c5835fbcaf5f5d..c316277f202e186d6eac15886c9c61a62a939b6b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
-#WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
-WWW_UPLOAD_URI = ../www
+WWW_UPLOAD_URI = neurodebian@neurodebian.ovgu.de:/home/neurodebian/www
+#WWW_UPLOAD_URI = ../www
 WWW_DIR = build/html/
 
 WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
@@ -22,7 +22,9 @@ html: pics source
        rsync -rvlhpt sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
+       cp neurodebian.cfg build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       ln -fs /usr/share/javascript build/html/
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
        cp -r build/src/lists $(WWW_DIR)/
        cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
@@ -52,10 +54,12 @@ source-stamp:
 
 
 updatedb:
+       $(BIGMESS) cachefiles -f
+       $(BIGMESS) updatedb
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=_files \
+        --exclude=debian --exclude=debian-local --exclude=debian-devel --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
        : # Touch stamp here so we get it updated on every upload
        touch $@-stamp