]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Force cache update in updatedb
[neurodebian.git] / Makefile
index f2876a1740f680b4cc18d330e4c647d5eb39eb55..c316277f202e186d6eac15886c9c61a62a939b6b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,13 @@
-#WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
-WWW_UPLOAD_URI = ../www
+WWW_UPLOAD_URI = neurodebian@neurodebian.ovgu.de:/home/neurodebian/www
+#WWW_UPLOAD_URI = ../www
 WWW_DIR = build/html/
 
 WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
 
+BIGMESS_OPTS = -c neurodebian_repo.cfg
+BIGMESS_CMD = PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess
+BIGMESS = $(BIGMESS_CMD) $(BIGMESS_OPTS)
+
 # Lentghy one due to updatedb
 all: updatedb upload-website mirmon
 # Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
@@ -20,6 +24,7 @@ html: pics source
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cp neurodebian.cfg build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       ln -fs /usr/share/javascript build/html/
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
        cp -r build/src/lists $(WWW_DIR)/
        cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
@@ -37,40 +42,24 @@ distclean: clean
 
 
 source: source-stamp
-source-stamp: build/db.db
-       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
-               --cfg neurodebian.cfg \
-               --db build/db.db \
-               --outdir build/src \
-               --pkgaddenum pkgs \
-               --extracts /home/www/neuro.debian.net/www/debian/extracts \
-               commandisirrelevant
-       rm -f html-stamp
+source-stamp: 
+       mkdir -p build/src/pkgs/
+       mkdir -p build/src/lists/
+       mkdir -p build/src/pkglists/
+       $(BIGMESS) mkpkgs  -d build/src/pkgs/
+       $(BIGMESS) mkaptcfgs -d build/src/lists/
+       $(BIGMESS) mkrepocfg > build/src/sources_lists
+       $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
        touch $@
 
 
-removecache:
-       -rm -rf build/cache
-
-removedb:
-       -rm -f build/db.db
-
-
-updatedb: removedb removecache build/db.db
-
-
-build/db.db:
-       mkdir -p build
-       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
-               --cfg neurodebian.cfg \
-               --db build/db.db \
-               updatedb
-       -rm -f source-stamp
-
+updatedb:
+       $(BIGMESS) cachefiles -f
+       $(BIGMESS) updatedb
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=_files \
+        --exclude=debian --exclude=debian-local --exclude=debian-devel --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
        : # Touch stamp here so we get it updated on every upload
        touch $@-stamp