]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Use new location at neuro.debian.net
[neurodebian.git] / Makefile
index fd125e1d1c34726cec7b2888f36021a6db2faac4..73c66be9619d1b54bd5bc1304dcb256f03f4d23a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,10 @@
-
-WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
+# old location
+#WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
+# brand new fancy one
+WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
 WWW_DIR = build/html
 
+all: html
 
 prep:
        if [ ! -d build ]; then mkdir build; fi
@@ -12,8 +15,10 @@ pics:
        $(MAKE) -C artwork
 
 
-html: pics prep source
+html: html-stamp
+html-stamp: pics prep source
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
+       touch $@
 
 
 clean:
@@ -26,21 +31,25 @@ distclean: clean
        -rm -rf cache
 
 
-source:
-       ./reblender generate \
+source: source-stamp
+source-stamp: build/db.db
+       tools/reblender generate \
                --cfg debneuro.cfg \
                --db build/db.db \
                --outdir build/src \
                --pkgaddenum pkgs
+       rm -f html-stamp
+       touch $@
 
 
-refresh-db:
+build/db.db:
        mkdir -p build
-#      rm -f build/db.db
-       ./reblender refreshdb \
+       tools/reblender refreshdb \
                --cfg debneuro.cfg \
                --db build/db.db
 
 
 upload-website: html
-       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR)/* $(WWW_UPLOAD_URI)
+
+.PHONY: prep