]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Use new location at neuro.debian.net
[neurodebian.git] / Makefile
index 45071d87ba04c3caa28fe5dc1612f02c1d316e9a..73c66be9619d1b54bd5bc1304dcb256f03f4d23a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,42 +1,55 @@
+# old location
+#WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
+# brand new fancy one
+WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
+WWW_DIR = build/html
 
-WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
-WWW_DIR = build/_build/html
-
+all: html
 
 prep:
-       mkdir -p build/src
-       cp -r sphinx/* build/src
+       if [ ! -d build ]; then mkdir build; fi
+       rsync -rvlhp sphinx/ build/src
+
+
+pics:
+       $(MAKE) -C artwork
 
 
-html: prep update-db
+html: html-stamp
+html-stamp: pics prep source
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
+       touch $@
 
 
 clean:
        -rm -rf build
+       $(MAKE) -C artwork clean
+
+
 
+distclean: clean
+       -rm -rf cache
 
-update-db:
-#              -r http://apsy.gse.uni-magdeburg.de/debian/dists/lenny/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/squeeze/Release \
-#      rm -f build/db.db
-       ./reblender \
+
+source: source-stamp
+source-stamp: build/db.db
+       tools/reblender generate \
+               --cfg debneuro.cfg \
                --db build/db.db \
                --outdir build/src \
-               --pkgaddenum pkgs \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/dapper/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/gutsy/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/hardy/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/intrepid/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/etch/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/sid/Release \
-               -t svn://svn.debian.org/blends/projects/med/trunk/debian-med/tasks/imaging \
-               -t svn://svn.debian.org/blends/projects/med/trunk/debian-med/tasks/imaging-dev \
-               -t svn://svn.debian.org/blends/projects/science/trunk/debian-science/tasks/neuroscience-cognitive \
-               -f fsl-doc -f fslview-doc -f fsl-atlases -f fsl-possum-data \
-               -f fsl-first-data -f fsl-feeds \
-               -p svn://svn.debian.org/blends/projects/science/trunk/debian-science/tasks/neuroscience-cognitive
+               --pkgaddenum pkgs
+       rm -f html-stamp
+       touch $@
+
+
+build/db.db:
+       mkdir -p build
+       tools/reblender refreshdb \
+               --cfg debneuro.cfg \
+               --db build/db.db
 
 
 upload-website: html
-       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR)/* $(WWW_UPLOAD_URI)
+
+.PHONY: prep