]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: minor -- just moved cachefiles into a separate rule
[neurodebian.git] / Makefile
index fa3f7dffdde909f9ccd3406051ae83cce7bf6164..4ae1d87989cd9a5f0f1b0a19676bdba6ce3d4a80 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -52,10 +52,12 @@ source-stamp:
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
        touch $@
 
-
-updatedb:
+cachefiles:
        $(BIGMESS) cachefiles -f
+
+updatedb: cachefiles
        $(BIGMESS) updatedb
+       -rm source-stamp
 
 upload-website: html
        rsync -rvzlhp --delete \
@@ -77,5 +79,5 @@ mirmon:
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \
         >| $(WWW_UPLOAD_URI)/mirrors-status.html
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon
+.PHONY: removedb removecache cachefiles updatedb upload-website clean distclean pics html mirmon