]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
* Also provide documents in single-file HTML format.
[debian/debian-policy.git] / Makefile
index efb5b7b927e1897e054f9e90df1354e5a2e589da..1d0852e5141aa6722af1acaeadf14ef2298acaf6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,11 @@ mime-policy.sgml: version.ent
 %.html/index.html: %.sgml
        LANG=C debiandoc2html $<
 
+%-1.html: %.sgml
+       LANG=C debiandoc2html -1 -b $*-1d $< && \
+        mv $*-1d.html/index.html $*-1.html && \
+        rmdir $*-1d.html
+
 %.html.tar.gz: %.html/index.html
        tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
@@ -33,6 +38,7 @@ mime-policy.sgml: version.ent
 
 # convenience aliases :)
 html: policy.html/index.html
+html-1: policy-1.html
 txt text: policy.txt
 ps: policy.ps
 pdf: policy.pdf