]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
* Also provide documents in single-file HTML format.
[debian/debian-policy.git] / Makefile
index b6c98f3330ce2c03dc366945dc19c3ceac7bcc6e..1d0852e5141aa6722af1acaeadf14ef2298acaf6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,11 @@ mime-policy.sgml: version.ent
 %.html/index.html: %.sgml
        LANG=C debiandoc2html $<
 
+%-1.html: %.sgml
+       LANG=C debiandoc2html -1 -b $*-1d $< && \
+        mv $*-1d.html/index.html $*-1.html && \
+        rmdir $*-1d.html
+
 %.html.tar.gz: %.html/index.html
        tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
@@ -33,14 +38,14 @@ mime-policy.sgml: version.ent
 
 # convenience aliases :)
 html: policy.html/index.html
+html-1: policy-1.html
 txt text: policy.txt
 ps: policy.ps
 pdf: policy.pdf
 policy: html txt ps pdf
 
 leavealone :=  $(FHS_HTML) $(FHS_FILES) $(FHS_ARCHIVE) \
-               fhs-2.0.tar.gz fhs-changes-2.1.html \
-               fsstnd-1.2.txt.gz libc6-migration.txt \
+               libc6-migration.txt \
                upgrading-checklist.html virtual-package-names-list.txt
              
 .PHONY: distclean