]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
* Also provide documents in single-file HTML format.
[debian/debian-policy.git] / Makefile
index 2335da48cb773a6c37a124d202245a41ce57b8f4..1d0852e5141aa6722af1acaeadf14ef2298acaf6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,11 @@ mime-policy.sgml: version.ent
 %.html/index.html: %.sgml
        LANG=C debiandoc2html $<
 
+%-1.html: %.sgml
+       LANG=C debiandoc2html -1 -b $*-1d $< && \
+        mv $*-1d.html/index.html $*-1.html && \
+        rmdir $*-1d.html
+
 %.html.tar.gz: %.html/index.html
        tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
@@ -33,21 +38,21 @@ mime-policy.sgml: version.ent
 
 # convenience aliases :)
 html: policy.html/index.html
+html-1: policy-1.html
 txt text: policy.txt
 ps: policy.ps
 pdf: policy.pdf
 policy: html txt ps pdf
 
 leavealone :=  $(FHS_HTML) $(FHS_FILES) $(FHS_ARCHIVE) \
-               fhs-2.0.tar.gz fhs-changes-2.1.html \
-               fsstnd-1.2.txt.gz libc6-migration.txt \
+               libc6-migration.txt \
                upgrading-checklist.html virtual-package-names-list.txt
              
 .PHONY: distclean
 distclean:
        rm -rf $(filter-out $(leavealone),$(wildcard *.html))
        rm -f $(filter-out $(leavealone),$(wildcard *.txt *.txt.gz *.html.tar.gz *.pdf *.ps))
-       rm -f *.lout* lout.li *.sasp* *.tex *.aux *.toc *.idx *.log *.out *.dvi
+       rm -f *.lout* lout.li *.sasp* *.tex *.aux *.toc *.idx *.log *.out *.dvi *.tpt
        rm -f `find . -name "*~" -o -name "*.bak" -o -name ".#*" -o -name core`
        rm -f version.ent
        rm -f *.rej *.orig