]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
RF: replace old-fashioned neurodebian.cfg with neurodebian_repo.cfg
[neurodebian.git] / Makefile
index fa3f7dffdde909f9ccd3406051ae83cce7bf6164..124f83757b15a9f70a81a9c17ba47121f0e8dc21 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4,8 +4,8 @@ WWW_DIR = build/html/
 
 WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
 
-BIGMESS_OPTS = -c neurodebian_repo.cfg
-BIGMESS_CMD = PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess
+BIGMESS_OPTS = -c neurodebian.cfg
+BIGMESS_CMD = PYTHONPATH=.:3rd/bigmess:$(PYTHONPATH) 3rd/bigmess/bin/bigmess
 BIGMESS = $(BIGMESS_CMD) $(BIGMESS_OPTS)
 
 # Lentghy one due to updatedb
@@ -52,10 +52,12 @@ source-stamp:
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
        touch $@
 
-
-updatedb:
+cachefiles:
        $(BIGMESS) cachefiles -f
+
+updatedb: cachefiles
        $(BIGMESS) updatedb
+       -rm source-stamp
 
 upload-website: html
        rsync -rvzlhp --delete \
@@ -77,5 +79,5 @@ mirmon:
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \
         >| $(WWW_UPLOAD_URI)/mirrors-status.html
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon
+.PHONY: removedb removecache cachefiles updatedb upload-website clean distclean pics html mirmon