]> git.donarmstrong.com Git - lilypond.git/blob - make/out/lilypond.spec
release: 1.3.106
[lilypond.git] / make / out / lilypond.spec
1 %define info yes
2
3 Name: lilypond
4 Version: 1.3.106
5 Release: 1
6 License: GPL
7 Group: Applications/Publishing
8 Source0: ftp.cs.uu.nl:/pub/GNU/LilyPond/development/lilypond-1.3.106.tar.gz
9 Summary: A program for printing sheet music.
10 URL: http://www.cs.uu.nl/~hanwen/lilypond
11 # Icon: lilypond-icon.gif
12 BuildRoot: /tmp/lilypond-install
13 Prereq: tetex
14
15 %description
16 LilyPond is a music typesetter.  It produces beautiful
17 sheet music using a high level description file as input.  LilyPond is
18 part of the GNU Project.
19
20 %package documentation
21 Summary: Prebuilt website containing all LilyPond documentation.
22 Group: Applications/Publishing
23 # BuildArchitectures: noarch
24
25 %description documentation
26
27 The documentation of LilyPond, both in HTML and PostScript.
28
29 %prep
30 %setup
31
32 %build
33
34 #
35
36 # DO NOT use % { configure } , it hardcodes all paths, runs libtool,
37 # so we can't do make prefix=/tmp/ install.
38
39 # In fact, do not take out the spaces between % and { , because RPM will gladly
40 # do a substitution anyway.
41
42 ./configure --disable-checking --disable-debugging --enable-printing --prefix=%{_prefix} --disable-optimise --enable-shared
43
44 make all
45
46 # urg
47 # %build documentation
48 # line 42: second %build
49 # ok, now make sure that lilypond package will succeed,
50 # even if documentation fails to build
51
52 make -C Documentation  || true
53 make htmldoc || true
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 mkdir -p $RPM_BUILD_ROOT/tmp/lilypond-rpm-doc
58
59 strip lily/out/lilypond midi2ly/out/midi2ly
60 make prefix="$RPM_BUILD_ROOT%{_prefix}" install
61 %if info=="yes"
62 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/info/* || true
63 %endif
64
65 mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
66 cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
67 cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
68
69 # urg
70 #%install documentation
71 #line 63: second %install
72 # again, make sure that main package installs even if doco fails
73 mkdir -p htmldocs/out
74 tar -C htmldocs -xzf out/htmldoc.tar.gz || true
75 mkdir -p out/examples/
76 tar -cf - input/  | tar -C out/examples/ -xf- || true
77
78 %ifos cygwin
79 # urg, this symlink doesn't come through on cygwin
80 # this is the way symlinks work over there, let's fake one
81 rm -f $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
82 echo '!<symlink>c:\\texmf\\fonts\\tfm\\public\\cm' > $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
83 %{fix_suffixes}
84 %endif
85
86 %post
87
88 touch /tmp/.lilypond-install
89 rm `find /var/lib/texmf -name 'feta*pk -print' -or -name 'feta*tfm -print'` /tmp/.lilypond-install
90 %if info=="yes"
91 /sbin/install-info %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
92 %endif
93
94 %preun
95 %if info=="yes"
96 if [ $1 = 0 ]; then
97     /sbin/install-info --delete %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
98 fi
99 %endif
100
101
102 %files
103 # hairy to hook it in (possibly non-existing) emacs
104 %doc lilypond-mode.el
105 %doc lilypond-font-lock.el
106
107 %ifnos cygwin
108 %{_prefix}/bin/abc2ly
109 %{_prefix}/bin/as2text
110 %{_prefix}/bin/convert-mudela
111 %{_prefix}/bin/etf2ly
112 %{_prefix}/bin/lilypond
113 %{_prefix}/bin/ly2dvi
114 %{_prefix}/bin/midi2ly
115 %{_prefix}/bin/mudela-book
116 %{_prefix}/bin/musedata2ly
117 %{_prefix}/bin/pmx2ly
118 %else
119 %{_prefix}/bin
120 %endif
121
122 %if info=="yes"
123 %{_prefix}/info/lilypond.info.gz
124 %{_prefix}/info/lilypond-internals.info.gz
125 %endif
126
127 %{_prefix}/man/man1/abc2ly.1.gz
128 %{_prefix}/man/man1/as2text.1.gz
129 %{_prefix}/man/man1/convert-mudela.1.gz
130 %{_prefix}/man/man1/etf2ly.1.gz
131 %{_prefix}/man/man1/lilypond.1.gz
132 %{_prefix}/man/man1/ly2dvi.1.gz
133 %{_prefix}/man/man1/midi2ly.1.gz
134 %{_prefix}/man/man1/mudela-book.1.gz
135 %{_prefix}/man/man1/musedata2ly.1.gz
136 %{_prefix}/man/man1/pmx2ly.1.gz
137
138 %{_prefix}/share/lilypond/
139 %{_prefix}/share/locale/*/LC_MESSAGES/lilypond.mo
140 # urg?
141 %{_prefix}/../etc/profile.d/lilypond.*
142
143 %files documentation
144 # this gets too messy...
145 # %doc input/*.ly
146 # verbatim include of input: list the directory without issuing a %dir 
147 %doc htmldocs/
148 %doc out/examples/
149 %doc mutopia/