]> git.donarmstrong.com Git - lilypond.git/blob - make/out/lilypond.spec
release: 1.3.70
[lilypond.git] / make / out / lilypond.spec
1 Name: lilypond
2 Version: 1.3.70
3 Release: 1
4 Copyright: GPL
5 Group: Applications/Publishing
6 Source0: ftp.cs.uu.nl:/pub/GNU/LilyPond/development/lilypond-1.3.70.tar.gz
7 Summary: A program for printing sheet music.
8 URL: http://www.cs.uu.nl/~hanwen/lilypond
9 # Icon: lilypond-icon.gif
10 BuildRoot: /tmp/lilypond-install
11 Prereq: tetex
12
13 %description
14 LilyPond is a music typesetter.  It produces beautiful
15 sheet music using a high level description file as input.  LilyPond is
16 part of the GNU Project.
17
18
19 %package documentation
20 Summary: Prebuilt website containing all LilyPond documentation.
21 Group: Applications/Publishing
22 # BuildArchitectures: noarch
23
24 %description documentation
25
26
27 The documentation of LilyPond, both in HTML and PostScript.
28
29 %prep
30 %setup
31
32 %build
33
34 %{configure} --disable-checking --disable-debugging --enable-printing --prefix=%{_prefix} --disable-optimise --enable-shared
35
36 make all
37
38 ln -s %{_prefix}/share/texmf/fonts/tfm/public/cm/ tfm
39
40 # urg
41 # %build documentation
42 # line 42: second %build
43 # ok, now make sure that lilypond package will succeed,
44 # even if documentation fails to build
45 make -C Documentation  || true
46 make htmldoc || true
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 mkdir -p $RPM_BUILD_ROOT/tmp/lilypond-rpm-doc
51
52 strip lily/out/lilypond midi2ly/out/midi2ly
53 make prefix="$RPM_BUILD_ROOT%{_prefix}" install
54 # gzip -9fn $RPM_BUILD_ROOT%{_prefix}/info/* || true
55
56 mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
57 cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
58 cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
59
60 # urg
61 #%install documentation
62 #line 63: second %install
63 # again, make sure that main package installs even if doco fails
64 mkdir -p htmldocs/out
65 tar -C htmldocs -xzf out/htmldoc.tar.gz || true
66 mkdir -p out/examples/
67 tar -cf - input/  | tar -C out/examples/ -xf- || true
68
69 %ifos cygwin
70 # urg, this symlink doesn't come through on cygwin
71 # this is the way symlinks work over there, let's fake one
72 rm -f $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
73 echo '!<symlink>c:\\texmf\\fonts\\tfm\\public\\cm' > $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
74 %{fix_suffixes}
75 %endif
76
77 %post
78
79 touch /tmp/.lilypond-install
80 rm `find /var/lib/texmf -name 'feta*pk -print' -or -name 'feta*tfm -print'` /tmp/.lilypond-install
81 # /sbin/install-info %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
82
83 %preun
84 if [ $1 = 0 ]; then
85  true #   /sbin/install-info --delete %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
86 fi
87
88
89 %files
90 # hairy to hook it in (possibly non-existing) emacs
91 %doc mudela-mode.el
92
93 %ifnos cygwin
94 %{_prefix}/bin/abc2ly
95 %{_prefix}/bin/convert-mudela
96 %{_prefix}/bin/mudela-book
97 %{_prefix}/bin/ly2dvi
98 %{_prefix}/bin/lilypond
99 %{_prefix}/bin/midi2ly
100 %else
101 %{_prefix}/bin
102 %endif
103
104 %{_prefix}/man/man1/midi2ly.1
105 %{_prefix}/man/man1/lilypond.1
106 %{_prefix}/man/man1/mudela-book.1
107 %{_prefix}/man/man1/ly2dvi.1
108 %{_prefix}/man/man1/convert-mudela.1
109 %{_prefix}/share/lilypond/
110 %{_prefix}/share/locale/*/LC_MESSAGES/lilypond.mo
111 # urg?
112 %{_prefix}/../etc/profile.d/lilypond.*
113
114 %files documentation
115 # this gets too messy...
116 # %doc input/*.ly
117 # verbatim include of input: list the directory without issuing a %dir 
118 %doc htmldocs/
119 %doc out/examples/
120 %doc mutopia/