]> git.donarmstrong.com Git - lilypond.git/blob - make/out/lilypond.spec
release: 1.3.129
[lilypond.git] / make / out / lilypond.spec
1 %define info yes
2
3 Name: lilypond
4 Version: 1.3.129
5 Release: 1
6 License: GPL
7 Group: Applications/Publishing
8 Source0: ftp.cs.uu.nl:/pub/GNU/LilyPond/development/lilypond-1.3.129.tar.gz
9 Summary: A program for printing sheet music.
10 URL: http://www.cs.uu.nl/~hanwen/lilypond
11 # Icon: lilypond-icon.gif
12 BuildRoot: /tmp/lilypond-install
13 Prereq: tetex
14
15 %description
16 LilyPond is a music typesetter.  It produces beautiful
17 sheet music using a high level description file as input.  LilyPond is
18 part of the GNU Project.
19
20 %package documentation
21 Summary: Prebuilt website containing all LilyPond documentation.
22 Group: Applications/Publishing
23 # BuildArchitectures: noarch
24
25 %description documentation
26
27 The documentation of LilyPond, both in HTML and PostScript.
28
29 %prep
30 %setup
31
32 %build
33
34 #
35
36 # DO NOT use % { configure } , it hardcodes all paths, runs libtool,
37 # so we can't do make prefix=/tmp/ install.
38
39 # In fact, do not take out the spaces between % and { , because RPM will gladly
40 # do a substitution anyway.
41
42 ./configure --disable-checking --disable-debugging --enable-printing --prefix=%{_prefix} --disable-optimise --enable-shared
43
44 make all
45
46 # urg
47 # %build documentation
48 # line 42: second %build
49 # ok, now make sure that lilypond package will succeed,
50 # even if documentation fails to build
51
52 make -C Documentation  || true
53 make htmldoc || true
54
55 %install
56
57
58
59 rm -rf $RPM_BUILD_ROOT
60 mkdir -p $RPM_BUILD_ROOT/tmp/lilypond-rpm-doc
61
62 strip lily/out/lilypond midi2ly/out/midi2ly
63 make prefix="$RPM_BUILD_ROOT%{_prefix}" install
64 %if info=="yes"
65 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/info/* || true
66 %endif
67
68
69
70 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/man/man1/* || true
71
72
73
74
75 mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
76 cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
77 cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
78
79 # urg
80 #%install documentation
81 #line 63: second %install
82 # again, make sure that main package installs even if doco fails
83 mkdir -p htmldocs/out
84 tar -C htmldocs -xzf out/htmldoc.tar.gz || true
85 mkdir -p out/examples/
86 tar -cf - input/  | tar -C out/examples/ -xf- || true
87
88 %ifos cygwin
89 # urg, this symlink doesn't come through on cygwin
90 # this is the way symlinks work over there, let's fake one
91 rm -f $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
92 echo '!<symlink>c:\\texmf\\fonts\\tfm\\public\\cm' > $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
93 %{fix_suffixes}
94 %endif
95
96 %post
97
98 touch /tmp/.lilypond-install
99 rm `find /var/lib/texmf -name 'feta*pk -print' -or -name 'feta*tfm -print'` /tmp/.lilypond-install
100 %if info=="yes"
101 /sbin/install-info %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
102 %endif
103
104 %preun
105 %if info=="yes"
106 if [ $1 = 0 ]; then
107     /sbin/install-info --delete %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
108 fi
109 %endif
110
111
112 %files
113 # hairy to hook it in (possibly non-existing) emacs
114 %doc lilypond-mode.el
115 %doc lilypond-font-lock.el
116
117 %ifnos cygwin
118 %{_prefix}/bin/abc2ly
119 %{_prefix}/bin/as2text
120 %{_prefix}/bin/convert-ly
121 %{_prefix}/bin/etf2ly
122 %{_prefix}/bin/lilypond
123 %{_prefix}/bin/ly2dvi
124 %{_prefix}/bin/midi2ly
125 %{_prefix}/bin/lilypond-book
126 %{_prefix}/bin/musedata2ly
127 %{_prefix}/bin/pmx2ly
128 %else
129 %{_prefix}/bin
130 %endif
131
132 %if info=="yes"
133 %{_prefix}/info/lilypond.info.gz
134 %{_prefix}/info/lilypond-internals.info.gz
135 %endif
136
137 %{_prefix}/man/man1/abc2ly.1.gz
138 %{_prefix}/man/man1/as2text.1.gz
139 %{_prefix}/man/man1/convert-ly.1.gz
140 %{_prefix}/man/man1/etf2ly.1.gz
141 %{_prefix}/man/man1/lilypond.1.gz
142 %{_prefix}/man/man1/ly2dvi.1.gz
143 %{_prefix}/man/man1/midi2ly.1.gz
144 %{_prefix}/man/man1/lilypond-book.1.gz
145 %{_prefix}/man/man1/musedata2ly.1.gz
146 %{_prefix}/man/man1/pmx2ly.1.gz
147
148 %{_prefix}/share/lilypond/
149 %{_prefix}/share/locale/*/LC_MESSAGES/lilypond.mo
150 # urg?
151 %{_prefix}/../etc/profile.d/lilypond.*
152
153 %files documentation
154 # this gets too messy...
155 # %doc input/*.ly
156 # verbatim include of input: list the directory without issuing a %dir 
157 %doc htmldocs/
158 %doc out/examples/
159 %doc mutopia/