]> git.donarmstrong.com Git - lilypond.git/blob - make/debian/rules
release: 0.1.27
[lilypond.git] / make / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4
5 package=lilypond
6
7 build:
8         $(checkdir)
9         ./configure --disable-checking --disable-debugging \
10                 --disable-printing --prefix=/usr --enable-optimise \
11                 --enable-shared
12         make all
13
14         touch build
15
16 clean:
17         $(checkdir)
18         -rm -f build
19         -make distclean
20         -rm -f {,*/}out/{*,.build} flower/config.{log,status}
21         -rm -f `find . -name "*~"`
22         -rm -rf debian/tmp debian/files* core debian/substvars
23
24 binary-indep:   checkroot build
25         $(checkdir)
26 # There are no architecture-independent files to be uploaded
27 # generated by this package.  If there were any they would be
28 # made here.
29
30 binary-arch:    checkroot build
31         $(checkdir)
32         -rm -rf debian/tmp
33         install -d debian/tmp
34         cd debian/tmp && install -d `cat ../dirs`
35         make prefix=`pwd`/debian/tmp/usr install
36         ln -fs ../../../doc/lilypond debian/tmp/usr/lib/texmf/doc/lilypond
37 # Must have debmake installed for this to work. Otherwise please copy
38 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
39         debstd -m BUGS TODO NEWS DEDICATION ANNOUNCE README
40         dpkg-gencontrol
41         chown -R root.root debian/tmp
42         chmod -R go=rX debian/tmp
43         dpkg --build debian/tmp ..
44
45 define checkdir
46         test -f debian/rules
47 endef
48
49 # Below here is fairly generic really
50
51 binary:         binary-indep binary-arch
52
53 checkroot:
54         $(checkdir)
55         test root = "`whoami`"
56
57 .PHONY: binary binary-arch binary-indep clean checkroot